Add new uid tables to about:memory

RESOLVED FIXED in Firefox 43

Status

()

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: terrence, Assigned: terrence)

Tracking

Trunk
mozilla44
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox43 fixed, firefox44 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

This will be necessary for evaluating the memory impact of moving tables over to the new key scheme.
I verified that the new measure shows up in about:memory and has a value of 0, as expected.
Attachment #8650681 - Flags: review?(n.nethercote)
Attachment #8650681 - Flags: review?(n.nethercote) → review+
Sorry to ask for re-review on this, but it was necessary to rewrite the patch it was based on. Specifically, we've moved the uid tables from the Chunk to the Zone, so the new patch reflects the new location and shares very little in common with the prior patch.
Attachment #8650681 - Attachment is obsolete: true
Attachment #8655547 - Flags: review?(n.nethercote)
Attachment #8655547 - Flags: review?(n.nethercote) → review+
https://hg.mozilla.org/mozilla-central/rev/15fa4c3a45ec
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
Backing out, since it seems bug 1196847 caused a pretty severe regression on splay.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
https://hg.mozilla.org/mozilla-central/rev/28dda1c9988d
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: mozilla43 → mozilla44
You need to log in before you can comment on or make changes to this bug.