2,200 instances of "Unexpected, plugin id not found!" emitted from gfx/layers/ipc/CompositorChild.cpp during linux64 debug testing

RESOLVED DUPLICATE of bug 1227666

Status

()

RESOLVED DUPLICATE of bug 1227666
3 years ago
3 years ago

People

(Reporter: erahm, Assigned: jimm)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(firefox43 affected)

Details

(Reporter)

Description

3 years ago
This regression happened some time in the past week. It is the #3 most verbose warning during testing. It occurs most often in the |reftest/tests/layout/| tests.

> 2202 [NNNNN] WARNING: Unexpected, plugin id not found!: file gfx/layers/ipc/CompositorChild.cpp, line 270

This warning [1], introduced in bug 1095754, shows up in the following test suites:

> mozilla-central_ubuntu64_vm-debug_test-crashtest-e10s-bm122-tests1-linux64-build2.txt:2202

It shows up in 966 tests. A few of the most prevalent:

> 42 - file:///builds/slave/test/build/tests/reftest/tests/layout/xul/tree/crashtests/585815.html
> 37 - file:///builds/slave/test/build/tests/reftest/tests/layout/generic/crashtests/947158.html
> 32 - file:///builds/slave/test/build/tests/reftest/tests/layout/style/crashtests/1164813-1.html
> 19 - file:///builds/slave/test/build/tests/reftest/tests/layout/svg/crashtests/458453.html
> 10 - file:///builds/slave/test/build/tests/reftest/tests/layout/mathml/crashtests/400157.xhtml
> 8 - file:///builds/slave/test/build/tests/reftest/tests/layout/generic/crashtests/1134667.html
> 7 - file:///builds/slave/test/build/tests/reftest/tests/widget/cocoa/crashtests/373122-1.html
> 7 - file:///builds/slave/test/build/tests/reftest/tests/layout/generic/crashtests/786740-1.html
> 6 - file:///builds/slave/test/build/tests/reftest/tests/layout/generic/crashtests/750066.html
> 5 - file:///builds/slave/test/build/tests/reftest/tests/layout/xul/crashtests/344228-1.xul

[1] https://hg.mozilla.org/mozilla-central/annotate/29b2df16e961/gfx/layers/ipc/CompositorChild.cpp#l270
(Assignee)

Comment 1

3 years ago
I guess I should take this, pretty sure it's something I did.
Assignee: nobody → jmathies
(Reporter)

Comment 2

3 years ago
This is now the #2 most verbose warning during testing.
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1227666
You need to log in before you can comment on or make changes to this bug.