Closed Bug 1196884 Opened 5 years ago Closed 5 years ago

Disable device discovery (again)

Categories

(Firefox OS Graveyard :: Runtime, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(firefox43 fixed)

RESOLVED FIXED
FxOS-S6 (04Sep)
Tracking Status
firefox43 --- fixed

People

(Reporter: fabrice, Assigned: fabrice)

References

Details

Attachments

(1 file)

On my dogfood device, mdnsd is getting crazy:

 PID PR CPU% S  #THR     VSS     RSS PCY UID      Name
  904  0  47% R     1   1568K    956K     mdnsr    /system/bin/mdnsd
Attachment #8650638 - Flags: review?(lissyx+mozillians)
Comment on attachment 8650638 [details] [diff] [review]
no-device-disco.patch

Review of attachment 8650638 [details] [diff] [review]:
-----------------------------------------------------------------

oh noes we risk bug 1171827 again :(
Attachment #8650638 - Flags: review?(lissyx+mozillians) → review+
Blocks: 1190791
There was a double-close issue fixed in Bug 1175387, and thought to be one of the reasons that make mdnsd crazy. The patch expected to avoid mdnsd running into spin situation.

Seems the issue still exists, so we're going to fix this issue in Bug 1194532.
https://hg.mozilla.org/mozilla-central/rev/1f52501f4e59
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S6 (04Sep)
So this setting is supposed to fix issues like bug 1171827? With today's Flame build (319MB), I can still reproduce this, even when I have the 'dom.presentation.discovery.enabled' pref set to false.
I'm using the automated test from bug 1198264 to test this.
Hmm, perhaps this is a different issue, this is much easier to reproduce in all kinds of automated tests in the latest Flame build.
See Also: → 1199564
(In reply to Martijn Wargers [:mwargers] (QA) from comment #6)
> So this setting is supposed to fix issues like bug 1171827? With today's
> Flame build (319MB), I can still reproduce this, even when I have the
> 'dom.presentation.discovery.enabled' pref set to false.
> I'm using the automated test from bug 1198264 to test this.

Althought discovery and registration are disabled, but in the initialization of |nsDNSServiceDiscovery|, it still starts the mdnsd service.

I've opened bug 1199564 to follow up.
Depends on: 1199564
You need to log in before you can comment on or make changes to this bug.