"Search using" in sidebar asks to change default search engine

RESOLVED WONTFIX

Status

SeaMonkey
Search
RESOLVED WONTFIX
16 years ago
9 years ago

People

(Reporter: Nick Kocharhook, Assigned: Samir Gehani)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I am pretty sure this changed right around 0.9.7. I have looked for a bug
related to this, but I didn't find one.

As of now, selecting a search engine in the "Search" sidebar's "using" popup
menu that is not the default causes a dialog to appear. The dialog asks you if
you want to change the default search engine to the selected one.

This dialog always appears every time you change the search engine. As far as
I'm aware, there is no way to turn it off (I've looked in the prefs...).

There are a couple of problems with the dialog. First of all, it asks you "Would
you like to make XX the default search engine" and then provides "Cancel" and
"OK" options. Those should say "No" and "Yes", because if you hit "Cancel" the
search engine is changed in the popup but the default remains the same.

Then there's the checkbox. This says "Change default engine without asking in
the future". However, this is NOT what I want it to do. I want there to be an
option so it doesn't ask me anymore about changing the default and just changes
the search engine locally.

I don't think this menu should even be offering to change the default search
engine. There is a way to do that, in the "Internet Search" Preferences panel.
Why would people want to change the default from the sidebar? I go to the
sidebar when I want to look up a word or find something on bugzilla. I use the
URL Bar when I want to search for something in Google, and I don't ever want
that to change.

If it *does* ask to change the default search engine, then there should be a way
to turn that behavior off. I think the checkbox should say "Don't ask me again
in the future" or something.

Comment 1

16 years ago
I would even say remove that menu completly. One of the reason's why I don't
like Windows is that it ask for everything, but not for the really important
things (like should I go bluescreen :-)). I think Mozilla has already enough
question dialog's which makes it hard for newbies to use it. Of course, I think
a lot of them are usefull, for example the alert when a page has  secure and non
secure objects, is even usefull for me as an "experienced" surfer. But this
dialog is really not.

Just make the behavior like when your choosing, the crux 
"changing the engine don't ask me in the future" is OK. It is really ok, if the
last engine used is displayed in the search sidebar.

Comment 2

16 years ago
--> search/claudius
Component: Sidebar → Search
QA Contact: sujay → claudius
(Reporter)

Comment 3

16 years ago
Let me see if I understand your suggestion. You think the dialog should be nixed
and the menu should act as though the dialog's checkbox was pressed? So
basically, the sidebar "Search" panel should be another way of changing the
global search prefs.

If this is what you're suggesting, I would disagree. I'd like Moz to go back to
the way it did things before 0.9.7 -- just change it locally. If I want to
change the global search engine, there's a place to do that in the Prefs.

I think it would be more confusing for people trying to use a different aspect
of Mozilla's search features (e.g.URL Bar), and it would certainly add another
step that wasn't necessary before (if you changed the engine in the sidebar, you
have to go back and change it back to use the URL bar). I'm not sure it's
obvious that those are linked.

In summary: If the menu does change the default search engine, it should tell me
so, and the dialog should be reworked. However, I would *much* prefer that the
behavior revert to what it was before, when the sidebar search was a different
animal.
Component: Search → Sidebar
QA Contact: claudius → sujay
(Assignee)

Comment 4

16 years ago
Marlon, any ideas for how to change this?  Clearly we need to address this since
we have some users who have voiced that they want certain behavior not provided
here: namely to opt out but not have the default engine change in the future.

Comment 5

16 years ago
What am I missing here? There's a simple checkbox on the dialog for "don't ask
next time" so if I'm happy changing the default whenever I change the search
with I can tell the dialog to not return. If I don't want to change the search
then I can hit no on the dialog. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

16 years ago
No, that's not exactly the situation. The dialog box says "Change default engine
without asking in the future". It doesn't make the option you select stick.

If it did that, I'd be happy. (Well, except for the phrasing of the buttons and
dialog text... see comment 1.)
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 7

16 years ago
--> search/claudius
Component: Sidebar → Search
QA Contact: sujay → claudius

Comment 8

16 years ago
There are some valid suggestions in this bug, but it appears to be devolving
into debate.

I suggest the discussion be taken offline and, if necessary, new bugs filed with
specific suggestions.

Comment 9

16 years ago
Is this still an issue in the 1.0 and 1.1a era?
(Reporter)

Comment 10

16 years ago
This bug still exists, exactly as reported.

Comment 11

16 years ago
This is not a bug. This is implemented as designed. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WONTFIX
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.