Converting <td colspan> in an unexpected way

VERIFIED INVALID

Status

()

Core
Editor
VERIFIED INVALID
16 years ago
16 years ago

People

(Reporter: Hakon, Assigned: kinmoz)

Tracking

Trunk
x86
Windows ME
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I have a table of 2 rows and 2 columns.
I want the upper/left TD to have colspan=2, so I enter that in "advanced options".
What happens then is that a third column seems to be added to each line. But
it's not able to edit.
Expected result:
-------
|     |
-------
|  |  |
-------

Build ID 2002011103
Reassign to editor
Assignee: ducarroz → jst
Component: Composition → DOM Core
Product: MailNews → Browser
QA Contact: sheelar → stummala
Editor not DOM
Assignee: jst → kin
Component: DOM Core → Editor: Core
QA Contact: stummala → sujay

Comment 3

16 years ago
This works exactly as expected for me with the following:

<html>
<body>
<table>
<tr><td colspan="2">Col1</td></tr>
<tr><td>Col1</td><td>Col2</td></tr>
</table>
</body>
</html>

Reporter (Hakon), please can you check to see whether this bug is still present
in a recent build (Moz1-RC1 or a new nightly build). If this bug does not occur
please can you resolve it worksforme. If it does occur please can you attach a
html snippet showing the problem.
(Reporter)

Comment 4

16 years ago
I still find it present.
You understand that this bug treats the behaviour of the Composer's graphical
user interface, assuming that you don't do any html coding manually, right?

Comment 5

16 years ago
No I didn't (at least until you told me)! 

Reporter, please follow the bug reporting guidelines
(http://www.mozilla.org/quality/bug-writing-guidelines.html) and redescribe this
bug.

Comment 6

16 years ago
Just for the record, the easiest way to achieve the behaviour you want is to
click in the left most cell and go to Table -> Join with Cell to the right.
(Reporter)

Comment 7

16 years ago
Yes, you're probably right.
There may also be a point with the current behaviour, because otherwise there
could be some potential dataloss (the second column would vanish). I'm closing this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Summary: <td colspan> doesn't work properly → Converting <td colspan> in an unexpected way

Comment 8

16 years ago
Verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.