PDF links open a blank page with plugins Adobe Reader DC or Sumatra PDF (Firefox 40, Windows XP)

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Larry, Unassigned)

Tracking

({qawanted})

40 Branch
x86
Windows XP
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150812163655

Steps to reproduce:

Tried to revert to previous version of Firefox.  Still had problem.  Tried to revert to previous version of Adobe Reader DC plugin.  Could not, even after uninstalling.


Actual results:

No change.  When click link leading to pdf get nothing, or if new tab open, just get blank page with "about:blank" in url field.


Expected results:

new tab should open up, or same tab goes to link address & opens up pdf using browser plugin.

Comment 1

3 years ago
Does it work with a fresh profile?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

If yes, rename the file mimeTypes.rdf to mimeTypes.rdf.old in your profile and restart FF.
Component: Untriaged → File Handling
Flags: needinfo?(lmleisten)
(Reporter)

Comment 2

3 years ago
Sorry for delay.  Busy & have to allot time before undertaking anything with PC.  Refreshed Firefox & it resolved problems.  Thanks so much.  RESOLVED.
Flags: needinfo?(lmleisten)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

3 years ago
OK, Have to amend previous post.  When refreshed Firefox & re-opened, pdf function worked.  Then after closing & re-opening again, to test page settings, Firefox tried to immediately update, but was cutoff.  But then resumed update when closing browser again.  After update, pdf function NOT WORKING again.  So, UNRESOLVED.  As suspected, latest update is interfering with Adobe Reader plug-in for PCs still running Windows XP (32 bit - SP3)

I'm going to refresh again & see if I can prevent update.  I had previous tried to revert to earlier version with no success.  Hopefully refresh will do that for me again.  Until there's a fix, there's a problem with the latest update.

UNRESOLVED

Comment 4

3 years ago
You have to go in about:preferences#applications and set the pdf reader you want to call when opening a PDF.
(Reporter)

Comment 5

3 years ago
Update.  After setting updates to "Check for updates, but let me choose whether to install them," somehow, after a few days or so, it seems browser was automatically updated.  Only discovered this AM after attempting to open up pdf link.

So, Mozilla support, when are u going to provide a fix with the latest update so pdfs will open in browser running Win XP?   Bottom line, this is a PITA & continued problems will only serve to drive me away from using Firefox in the future.

Comment 6

3 years ago
The PDF viewer works on Win XP. It an issue on your OS, probably with the PDF file association to a 3rd-party reader.
(Reporter)

Comment 7

3 years ago
Yes, it's clear to me that the latest browser update is not fully compatible with Win XP, specifically with Adobe Acrobat Reader.  After refreshing Firefox, problem is eliminated until browser updates itself.  Have set options for browser not to automatically update, but for some reason, something along the way chooses to reset that setting w/o my knowledge.  Bottom line, since Mozilla is aware of this problem, it would be nice to have a fix so I won't have continually have to refresh every time browser decides to update itself despite my setting that it not.
(Reporter)

Comment 8

3 years ago
UPDATE.  OK, browser once again updated to current version: 40.0.3.  Just did another reset & pdf links are working.  But an hour ago they weren't, so I had to "Refresh Firefox" again . . . for the 3rd or 4th time.

So, something in browser, not the latest update per se, but something in the most recent update is disabling the pdf function after some time.  Not sure what, but something is causing the loss of function of the embedded Adobe Reader, which did not occur with the prior version.

Is someone working on a fix, or all of this is falling upon deaf ears?
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 9

3 years ago
Set about:config > pdfjs.disabled = true and verify the Acrobat Reader plugin is selected to open and read PDF in about:preferences#applications

It should fied your issue.

Updated

3 years ago
Component: File Handling → PDF (Adobe)
Product: Firefox → Plugins
Version: 40 Branch → unspecified
(Reporter)

Comment 10

3 years ago
Set about:config > pdfjs.disabled = true.  Was = false.

Confirmed about:preferences#application settings.  All 4 listed Adobe Acrobat applications set to "Use Adobe Acrobat(in Firefox)."  First listed app, Adobe Acrobat Document was previously set to "Always Ask."

After making above changes, pdf still not opening.  Something else in the "Refresh Firefox" app needs to be identified as Refresh Firefox @ least results in pdf links temporarily working.

Comment 11

3 years ago
Did you try the Adobe support forum? Maybe it's a bug in the latest update of this plugin.

If you install a different PDF Reader (like Sumatra PDF), does it work as expected?
(Reporter)

Comment 12

3 years ago
UPDATE.  Went through MSFT update, which required reboot.  When re-opened Firefox browser, home page settings reset to default.  So took opportunity to, once again, Refresh Firefox.  Confirmed that pdf links were working (for now).  Took opportunity to check settings.  Surprisingly, under about:preferences#applications, only 3 (previously 4) Adobe Plugins listed.  All set to "Use Adobe Acrobat" (in Firefox).  Previous plugin, which was just labeled "Adobe Acrobat Document," which had been set to "Always Ask" that I had reset to "Use Adobe Acrobat (in Firefox) is NOW MISSING.

Any idea?

Once I detect pdf links are no longer working, I plan to revisit this page under Options-Applications to see if 4 Adobe plugin pops up.  Will report back, but appreciate any further ideas.

Will research Adobe forums for info, but after first brush don't see anything that sticks out.  Only issue raised is Java.  Have Version 7, Update 72 installed.  Will try to update to Version 8, Update 60.  Again, issue is I'm still running Win XP, not Win 7 or 8.  Let's see how it goes since there presently doesn't seem to be a fix here right now.
(Reporter)

Comment 13

3 years ago
Thought problem might be rooted in Adblock plugin, so did not install after last Refresh.  All good . . . for about 6 hours.  Was checking about every hour or.  Just returned after several hours away from PC.  PDFs link not working.

So, what could be the issue if after Refresh, pdf links work, but then after some time, let's 4-5 hours, capability disappears?  Any ideas?

Comment 14

3 years ago
do you have any error message in the cosnsole output (ctrl+shift+k) when the blank page is displayed?
If you change the application settings to download the PDF instead of viewing in Firefox, does Firefox download it?
(Reporter)

Comment 15

3 years ago
Now when I click pdf link @ most website, a blank page no longer opens up.  Instead, I get no response.  The URL remains the same.  If I click "open in new tab," I get a blank page with the correct target URL, instead of "About:blank."  When I open up console in such page, when trying open up pdf or download pdf, there is NO text present.  Console is blank.

I have not been able to find anything in Adobe Reader forum.  When the problem first surfaced, I tried reverting back to the previous version of Reader with no success.  As previously stated, I do encounter a problem with the most current Java script as it advises me it won't be fully functional due to fact I don't have Win 7 or 8 or 10.

As previously stated, the pdf links DO WORK TEMPORARILY after going thru the "Refresh Firefox" process.  That leads me to conclude that something is acting to prevent pdf links from working that do not immediately take effect after a Refresh.  At this point, I've abandoned the "Refresh" remedy.  This points to a problem with Firefox browser since all was working well until installing latest update.

I now, when available, rely on the "Open Target in IE" option.  So, to answer your question, pdf links work perfectly in IE.  This also points to a problem with Firefox.

I've downloaded & installed Sumatra pdf & set Adobe pdf applications to open in Sumatra PDF. Doesn't work.  No change.  Again, this points to a proble with Firefox.

Sorry, but FACTS indicate that problem rests in Firefox browser since pdf links work perfectly in IE.  Too often vendors are quick to point the finger elsewhere.  I think best to be objective & weigh the facts.  This is a bug that remains unresolved.

Updated

3 years ago
Component: PDF (Adobe) → Plug-ins
Product: Plugins → Core

Updated

3 years ago
OS: Unspecified → Windows XP
Hardware: Unspecified → x86
Summary: PDF links no longer work since downloading latest version of Firefox (40.0.2) & latest Adobe Reader DC plug-in(11.0.8). Running XP → PDF links no longer work since downloading latest version of Firefox (40.0.2)
Version: unspecified → 40 Branch

Comment 16

3 years ago
As Sumatra PDF fails too, title has been changed.
Summary: PDF links no longer work since downloading latest version of Firefox (40.0.2) → PDF links open a blank page with plugins Adobe Reader DC or Sumatra PDF (Firefox 40, Windows XP)

Comment 17

3 years ago
I'm a litte bit ouf of idea. Any thoughts, benjamin?
Feel free to retriage if it's the wrong component.
Flags: needinfo?(benjamin)
(Reporter)

Comment 18

3 years ago
FYI, been doing more research.  Out of curiosity I disabled Firefox's built-in pdf viewer found under Add-ons.  Now when I click pdf link, window opens to download pdf. 

It's a quasi-fix, as I can now access pdf links instead of opening in IE, which requires logging into (again) to a secure website.   It's not a full fix since I still cannot view pdf in the browser.

Hoping this info may be of help in identifying the problem.

Comment 19

3 years ago
I didn't know you had the add-on pdf.js installed in your profile. Honestly, if you are not a beta tester, there is no reason to install it, Firefox has the same native PDF Viewer.

Even if the native pdf viewer is disabled (or the add-on pdf.js), you can still open PDFs directly in the browser with Adobe Reader or Sumatra, both have a plugin and they load the PDF in the tab.
You can change that in about:preferences#applications http://imgur.com/VZKDo8Y
(Reporter)

Comment 20

3 years ago
Not sure why u label the pdf.js as a "beta tester" add-on.  I certainly did not add it to my browser.  I believe it was installed by default.  Here's the text that is provided when I click the "More" link in the Add-ons Manager:
--------------------------------------
"PDF ViewerUses HTML5 to display PDF files directly in Firefox. Visit our Github project for feedback and issue reports: https://github.com/mozilla/pdf.js

Note: The Adobe Acrobat plugin (or other PDF viewer NPAPI add-on) may conflict with this viewer and should be disabled."

Note: PDF.js is part of the Firefox since version 19. The extension is mostly used to bring newer version of the PDF.js library to the older Firefox version. It will be marked as incompatible starting from the Firefox version 35."
-------------------------------------
BOTTOM LINE, the PDF viewer has likely been part of my Firefox profile for sometime is not something I've had to directly "add-on" each time I've refreshed the browser.  I've removed it.

Now, I'm still looking for the ability to open PDFs in the browser.  Any more ideas?

Updated

3 years ago
Flags: needinfo?(benjamin) → needinfo?(ryanvm)
Keywords: qawanted
(Reporter)

Comment 21

3 years ago
UPDATE.  Installed Firefox update, released late last week, over weekend.  Today, out of curiosity, clicked pdf line.  Surprise, pdf opened in browser -- did not open window prompting me to save pdf in a selected folder.  Checked profile, specifically, under Add-ons.  No PDF viewer is present (having previously removed it).  Bottom line, pdf links now appear to be working with new update.  Was bug detected & fix provided with new update?  TIA.
My gut is telling me that it was likely some bizarre conflict between the built-in PDF viewer and the old pdf.js extension that somehow got installed in your profile somewhere along the way.

Glad to hear things are working for you now, Larry! Thanks for bearing with us trying to track this down. I'm going to resolve this bug as WORKSFORME now (since we don't know of a specific patch that landed in Firefox to fix your issue), but feel free to reopen the bug and needinfo? request me if you run into problems again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago3 years ago
Flags: needinfo?(ryanvm)
Resolution: --- → WORKSFORME
(Reporter)

Comment 23

3 years ago
Pdf links working fine, only now, running into problem I haven't experienced in about a year or so -- browser freezing up, likely due to Silverlight plugin failure.  Vaguely recall there was an option to "quarantine" Silverlight, so when it fails it doesn't take the whole browser down.  Always believed this was a memory issue.  Just letting you know. . .  I plan to upgrade to 64 bit Win 7 in a few weeks, which may remedy this issue.  But for now, this is a returning "old" problem.
You need to log in before you can comment on or make changes to this bug.