Consider submitting SSL error reports through Telemetry

RESOLVED DUPLICATE of bug 1120377

Status

()

RESOLVED DUPLICATE of bug 1120377
3 years ago
3 years ago

People

(Reporter: gfritzsche, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox43 affected)

Details

(Whiteboard: [unifiedTelemetry])

(Reporter)

Description

3 years ago
We have a separate submission path and controlling prefs for SSL error reporting:
https://dxr.mozilla.org/mozilla-central/rev/095988abdc560bf8ba07a94a425c6922a3e9bfd6/browser/base/content/browser.js#2823
https://gecko.readthedocs.org/en/latest/browser/base/sslerrorreport/index.html

We should consider submitting them through Telemetry, which now comes basically down to e.g.:
> TelemetryController.submitExternalPing("ssl-error", reportObject, options)

This lets it use a common send implementation, local persistence, feed through our common datapipeline, ... and we could make it obey global datareporting upload preferences.
(Reporter)

Comment 1

3 years ago
Or is that what the CertViolation ping in bug 1120377 is about?
Flags: needinfo?(benjamin)

Comment 2

3 years ago
This is all the same thing, yes. They went ahead with something else for cert violations earlier, but now we should use the common system.
Flags: needinfo?(benjamin)
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1120377
You need to log in before you can comment on or make changes to this bug.