User is able to drag elements when customization window is closed

VERIFIED WONTFIX

Status

()

Firefox
Toolbars and Customization
VERIFIED WONTFIX
3 years ago
2 years ago

People

(Reporter: arni2033, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox43 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8651028 [details]
2015.08.21 17-06-13.webm

In fact, there's no real consequences of that, but I couldn't think of better Summary.

STR:
1. Open new window with 2 tabs: New tab 1, New tab 2
2. Switch to New tab 1
3. Enter customizing mode
4. Move mouse over searchbar (or any other element) and press left mouse button (don't release it)
5. Press Ctrl+Tab (or Ctrl+W)
6. Move mouse the next instant (while customization mode is still active)

Result:       You can now move "searchbar" (or other element) without customization mode
Expectations: Such actions shouldn't be allowed

Comment 1

3 years ago
IIRC, there is no way to programmatically cancel the drag after it has started. Even if there was, considering there are no consequences and that you can really only hit this if you're trying to do so, I don't think we should spend time on this.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

3 years ago
(In reply to :Gijs Kruitbosch from comment #1)
> IIRC, there is no way to programmatically cancel the drag after it has started.
Maybe somebody could spend time on this and send his own patch?...
Well anyway, do you think that bug 1187543 should also be closed? GoogleChrome doesn't do such things

Comment 3

3 years ago
(In reply to arni2033 from comment #2)
> (In reply to :Gijs Kruitbosch from comment #1)
> > IIRC, there is no way to programmatically cancel the drag after it has started.
> Maybe somebody could spend time on this and send his own patch?...

It is literally impossible to fix this cross-platform (specifically, OS X does not expose APIs to cancel a drag mid-drag, see comments in bug 977957). It's also, as I explained before, not really reproducible unless you actively try to do so, and it has no bad consequences as soon as you let go of the mouse. So no, I think we're not even interested in a contributed patch because it'll increase code complexity for little to no gain.

> GoogleChrome doesn't do such things

Chrome doesn't have a customization window, last I checked.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

3 years ago
(In reply to :Gijs Kruitbosch from comment #3)
> Chrome doesn't have a customization window, last I checked.
You people on bugzilla very like to pretend that everyone but you is saying nonsense.
I obviously was referring to bug 1187543. Thanks for checking though.
(Reporter)

Comment 5

3 years ago
Btw I encountered this the 1st time when I got alert() in background window, so you're also wrong about "you can really only hit this if you're trying to do so" part.
I wrote such STR here just so that other people could reproduce this.
(note that in this comment I'm not saying that your decision is wrong, but some of your arguements are)
(Reporter)

Updated

2 years ago
Has STR: --- → yes
(Reporter)

Updated

2 years ago
See Also: → bug 986868
You need to log in before you can comment on or make changes to this bug.