<link></link> causes XML parse error in XHTML as XML document

RESOLVED FIXED

Status

()

--
major
RESOLVED FIXED
17 years ago
16 years ago

People

(Reporter: caillon, Assigned: harishd)

Tracking

({regression, testcase})

Trunk
x86
Linux
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fix in hand], URL)

Attachments

(2 attachments)

Using linux 2002011108 - bz and hixie both were able to reproduce this.

XML Parsing Error: mismatched tag. Expected: </link>.
Location: http://www.zbarsky.org:8000/~bzbarsky/test.xml
Line Number 9, Column 4: 

</head>
---^
Keywords: regression, testcase
This is likely to get fixed by the patch in bug 119399
Depends on: 119399
(Assignee)

Comment 3

17 years ago
Boris: That's what I thought and hoped :) but unfortunately the fix, in bug
119399, does not fix this problem. I did find a bug in expat, and have a fix in
hand.
(Assignee)

Comment 4

17 years ago
Created attachment 64845 [details] [diff] [review]
patch v1.0.

Buffer position should be updated such that it points after </foo>.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Whiteboard: [fix in hand]
Comment on attachment 64845 [details] [diff] [review]
patch v1.0.

r=heikki

Just test some open/close combos as well to make sure we don't regress because
of this, and if you haven't tested XHTML run through those testcase as well.
Attachment #64845 - Flags: review+
(Assignee)

Comment 6

17 years ago
Comment on attachment 64845 [details] [diff] [review]
patch v1.0.

jst sez sr=
Attachment #64845 - Flags: superreview+
(Assignee)

Comment 7

17 years ago
FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Updated

16 years ago
QA Contact: petersen → rakeshmishra
You need to log in before you can comment on or make changes to this bug.