Black camera until video is disabled/enabled or black forever

RESOLVED DUPLICATE of bug 1182329

Status

defect
RESOLVED DUPLICATE of bug 1182329
4 years ago
4 years ago

People

(Reporter: alex_mayorga, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20150821])

Attachments

(2 attachments)

Reporter

Description

4 years ago
¡Hola!

So as part of "Firefox 41 Beta 3 Testday, August 21st"[1] I tried a Hello call with satdav and the video was black initially for us both using Nightly.

My video eventually worked once I "Disable video" and then "Enable video" once.

For satdav video never worked and remained black the entire time.

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:43.0) Gecko/20100101 Firefox/43.0 ID:20150821030204 CSet: 095988abdc560bf8ba07a94a425c6922a3e9bfd6

alex_mayorga's camera is "QuickCam Pro for Notebooks"[2]

The Hello link is/was https://hello.firefox.com/Tfxwflo2U_w#2xXfv7TVE2i_Fxb8zOMJbg

1 https://quality.mozilla.org/event/firefox-41-beta-3-testday-august-21st/
2 http://support.logitech.com/en/product/quickcam-pro-for-notebooks
Reporter

Comment 1

4 years ago
This is the black video from my end...
Posted image Mozilla1.png
I am on windows 10 education version and I have also got http://www.argos.co.uk/static/Product/partNumber/9131451.htm 

for the PC its using the default firewall aka windows defender
Reporter

Updated

4 years ago
Whiteboard: [testday-20150821]
Reporter

Comment 3

4 years ago
¡Hola David!

http://trust.com/en/product/17405-primo-webcam says "For extra functionality download driver at www.trust.com/17405/drivers ".

Perhaps you need a driver update?

Same page also just lists "Windows 8, 7, Vista or XP" as "Minimum requirements" so perhaps it is not yet Windows 10 ready?

Just some thoughts but I think this bug lies on the Loop or Firefox side...
Flags: needinfo?(david.weir)
Hello it's working fine on windows 10 as vidyo and Skype is accepting it it only seems to be only firefox hello what is not
Flags: needinfo?(david.weir)
Please can you both try reproducing the issue on https://mozilla.github.io/webrtc-landing/gum_test.html with the Video + Audio button.

It might also be that we need to split this bug into two, as there seems to be different issues here.
I cant repo it on the test server
Reporter

Comment 7

4 years ago
¡Hola Mark!

Mystery solved!

I had to right click on the big black video then click on "Play"

Is this related to the fact that I "click-to-play all the tings"?
Flags: needinfo?(standard8)
(In reply to alex_mayorga from comment #7)
> Mystery solved!

Aha!

> I had to right click on the big black video then click on "Play"
> 
> Is this related to the fact that I "click-to-play all the tings"?

Do you have the media.autoplay.enabled set to false?
Flags: needinfo?(standard8) → needinfo?(alex_mayorga)
Reporter

Comment 9

4 years ago
(In reply to Mark Banner (:standard8) from comment #8)

> Do you have the media.autoplay.enabled set to false?

You're a wizard!

media.autoplay.enabled;false
Flags: needinfo?(alex_mayorga)
Ok, thanks for checking that, this means its a dupe of bug 1182329.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1182329
You need to log in before you can comment on or make changes to this bug.