Webrtc overrides Alt-D during call for Tabs sharing devices in menu bar

RESOLVED WORKSFORME

Status

()

P3
normal
Rank:
30
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: thelodger, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Accessibility])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150819100530

Steps to reproduce:

* Use Firefox 40 on Ubuntu 15.04
* Open Hello and start a chat
* Press Alt + D
 


Actual results:

* Firefox selects the newly added "Tabs sharing devices"

After closing Hello:

* Using Alt + D to select the Address Bar does not always work and nothing happens


Expected results:

* Firefox selects the Address Bar

After closing Hello:

* Firefox selects the Address Bar
(Reporter)

Comment 1

3 years ago
Default menu bar shortcut chars are "f, e, v, s, b, t, h".
Alternate options for the "Tabs sharing devices" Alt + '' shortcut char are "i, r, g, c, n", at least ones that I can't see doing anything atm.

If one of those could be used, that would be super! =D

Comment 2

3 years ago
is there a way to find a free letter?
Rank: 25
Flags: needinfo?(sfranks)
Priority: -- → P2
Whiteboard: [Accessibility]
Hey David, would you be able to help here?
Flags: needinfo?(sfranks) → needinfo?(dbolter)
Hi! Does this wiki page help?
https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly

Please needinfo me again if that doesn't provide a solution for you.
Flags: needinfo?(dbolter)
Rank: 25 → 30
Priority: P2 → P3
Component: General → Client
(Reporter)

Comment 5

3 years ago
Hi folks,

I was just on a chat on https://meet.jit.si/ and noticed the same problem after giving audiovisual permissions to Jitsi. I think this should be moved to wherever the audiovisual api hooks are in Firefox. Any idea where that is?
(Reporter)

Comment 6

3 years ago
Hi folks,

Have been using https://appear.in/ (use ALL the WebRTC services) for chat with work colleagues for the last week and the same problem happens on my work laptop (Firefox 42 on Ubuntu 14.04).

Alt-D hasn't returned to the task of focussing the Address Bar after being used for "Tabs sharing devices" with two other services so I'm confident now that isn't a Hello-specific bug.

The only way I've found to remedy is to restart Firefox. Any suggestions on where this bug should be moved to would be great as I can't tell if this falls under Loop post-pivot.

Needinfo-ing Mark as he was the last to edit the bug =)
Flags: needinfo?(standard8)
If this is happening outside the conversation window, this seems like more of a Firefox bug. Moving to the right place. 

I think Florian should be able to point people to the right bit of code.
Component: Client → Device Permissions
Flags: needinfo?(standard8)
Product: Hello (Loop) → Firefox
The menu is created the first time it is used at http://mxr.mozilla.org/mozilla-central/source/browser/modules/webrtcUI.jsm?rev=2524d0d7a041#763
When it's no longer in use, it's hidden (not removed), at http://mxr.mozilla.org/mozilla-central/source/browser/modules/webrtcUI.jsm?rev=2524d0d7a041#832 which probably explains why the accesskey still goes to it (I'm somewhat surprised a hidden menu prevents the accesskey from focusing something else that's visible).

As a workaround, Command+L should work to focus the address bar.
(Reporter)

Comment 9

3 years ago
Thanks for the replies folks!

I've been using ctrl+L here since Florian suggested it and it works perfectly, even if it plays heck with my muscle memory =P
Support for Hello/Loop has been discontinued.

https://support.mozilla.org/kb/hello-status

Hence closing the old bugs. Thank you for your support.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INCOMPLETE

Comment 11

2 years ago
This is not just related to Hello, reopening. (On behalf of a friend, for whom this is a major gripe with Firefox.)

Alt+G seems like a reasonable shortcut?
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INCOMPLETE → ---
Summary: Hello overrides Alt-D during call for Tabs sharing devices in menu bar → Webrtc overrides Alt-D during call for Tabs sharing devices in menu bar
Tried in Fedora 25, Nightly.  In a call, Alt-D selects the addressbar data.  (Ctrl-L works too)  Also works while sharing a screen in appear.in, and with gum_test while sharing windows, etc.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.