TEST-UNEXPECTED-FAIL | mailnews/base/test/unit/test_accountMigration.js | xpcshell return code: 0 [Exception NS_ERROR_FAILURE [nsIPermissionManager.add] in mailnewsMigrator.js]

RESOLVED FIXED in Thunderbird 44.0

Status

Thunderbird
Migration
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Stefan Sitter, Assigned: Magnus Melin)

Tracking

({intermittent-failure})

42 Branch
Thunderbird 44.0
intermittent-failure

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 1193200])

(Reporter)

Description

2 years ago
<https://treeherder.mozilla.org/logviewer.html#?job_id=22835&repo=comm-central>

05:11:05 WARNING - TEST-UNEXPECTED-FAIL | mailnews/base/test/unit/test_accountMigration.js | xpcshell return code: 0 

 05:11:05 INFO - PROCESS | 9960 | [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIPermissionManager.add]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: resource://gre/modules/mailnewsMigrator.js :: MigrateABRemoteContentSettings/migrateAddress :: line 135" data: no]

05:11:05 INFO - PROCESS | 9960 | -- Exception object --
05:11:05 INFO - PROCESS | 9960 | + toString (function) 3 lines
05:11:05 INFO - PROCESS | 9960 | + message (string) 'Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIPermissionManager.add]'
05:11:05 INFO - PROCESS | 9960 | + result (number) 2147500037
05:11:05 INFO - PROCESS | 9960 | + name (string) 'NS_ERROR_FAILURE'
05:11:05 INFO - PROCESS | 9960 | + filename (string) 'resource://gre/modules/mailnewsMigrator.js'
05:11:05 INFO - PROCESS | 9960 | + lineNumber (number) 135
05:11:05 INFO - PROCESS | 9960 | + columnNumber (number) 0
05:11:05 INFO - PROCESS | 9960 | + inner (object) null
05:11:05 INFO - PROCESS | 9960 | + data (object) null
05:11:05 INFO - PROCESS | 9960 | + stack (string) 425 chars
05:11:05 INFO - PROCESS | 9960 | + location (object) JS frame :: resource://gre/modules/mailnewsMigrator.js :: MigrateABRemoteContentSettings/migrateAddress :: line 135
05:11:05 INFO - PROCESS | 9960 | *
05:11:05 INFO - PROCESS | 9960 | -- Stack Trace --
05:11:05 INFO - PROCESS | 9960 | MigrateABRemoteContentSettings/migrateAddress@resource://gre/modules/mailnewsMigrator.js:135:7
05:11:05 INFO - PROCESS | 9960 | MigrateABRemoteContentSettings@resource://gre/modules/mailnewsMigrator.js:156:11
05:11:05 INFO - PROCESS | 9960 | migrateMailnews@resource://gre/modules/mailnewsMigrator.js:31:5
05:11:05 INFO - PROCESS | 9960 | run_test@/builds/slave/test/build/tests/xpcshell/tests/mailnews/base/test/unit/test_accountMigration.js:60:3
05:11:05 INFO - PROCESS | 9960 | _execute_test@/builds/slave/test/build/tests/xpcshell/head.js:509:7
05:11:05 INFO - PROCESS | 9960 | @-e:1:1
(Reporter)

Comment 1

2 years ago
Same error is reported on comm-aurora builders but not on comm-beta.
Summary: TEST-UNEXPECTED-FAIL | mailnews/base/test/unit/test_accountMigration.js | xpcshell return code: 0 → TEST-UNEXPECTED-FAIL | mailnews/base/test/unit/test_accountMigration.js | xpcshell return code: 0 [Exception NS_ERROR_FAILURE [nsIPermissionManager.add] in mailnewsMigrator.js]
Version: 43 → 42

Comment 2

2 years ago
Is nsIPermissionManager something from toolkit?
Did I hear correctly that toolkit has removed support for some protocols needed for TB so it is currently not possible to manage the permissions to show/block remote images in messages?
May this be the same problem?
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1199909
(Reporter)

Comment 4

2 years ago
Aceman, do you have a bug number for the problem described by you? Last time I checked this test failure was only reported on comm-central and comm-aurora builders but not on comm-beta or comm-esr38. Could mean those branches are not affected, or maybe the tests don't run there.
Keywords: intermittent-failure
(Assignee)

Comment 5

2 years ago
I think you're talking about bug 1193200, which indeed looks like the cause here.
Depends on: 1193200
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 43

2 years ago
Fixed by bug 1193200.
Assignee: nobody → mkmelin+mozilla
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug 1193200]
Target Milestone: --- → Thunderbird 44.0
You need to log in before you can comment on or make changes to this bug.