Scrollbars missing when displaying original HTML

RESOLVED INVALID

Status

Thunderbird
Untriaged
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: M. LaPlante, Unassigned)

Tracking

38 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8651521 [details]
scroll.txt

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/44.0.2403.157 Safari/537.36

Steps to reproduce:

I receive regular email from a specific individual that always renders incorrectly in Thunderbird.  I assume they're using a bulk mailer or CMS.  Viewing the message in the message view pane is prone to cutting off the bottom of the message whenever it's larger than the display area on the screen.  For some reason scroll bars are never displayed allowing one to view the bottom of the messages.  

The "Original HTML" view is most affected.  Plain text view seems to work OK.  I don't see anything in the HTML forcibly disabling scroll bars or scrolling.

I've sanitized an example message and attached the raw message body as a text file.  Obviously the issue is most apparent if your display area/resolution are small enough that you cannot see the entire message on screen at once.

mailx -s "scroll bug" -a "MIME-Version: 1.0" -a "Content-Type: multipart/alternative;boundary=----=_NextPart_000_3BFB_01D0C52E.12FD44E0" [recipient email] < scroll.txt


Actual results:

The message is cut off at the bottom of the message viewer.  There are no scroll bars allowing one to see the bottom of the message.


Expected results:

Scroll bars should allow viewing the entire message.

Comment 1

3 years ago
I don't think this is a bug in Thunderbird. The message explicitly states that overflow of the HTML's <body> should be hidden. Thunderbird respects this setting. See this line of the attachment:

> ><body style="overflow: hidden;" spellcheck="true"
(Reporter)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.