Firefox crashes on Google+ @ libcairo.so.2.11400.2@0x22630 with layers.acceleration.force-enabled

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: jonathan_haas, Unassigned)

Tracking

({crash})

40 Branch
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted], crash signature)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150812142102

Steps to reproduce:

Opening a Hangout conversation on Google+ using Firefox 40 on Fedora 22, KDE Plasma 5.3 beta


Actual results:

Firefox crashes reliably. Also on some other sites.

https://crash-stats.mozilla.com/report/index/bp-ece60eb4-9905-4b57-8ead-bae932150823
https://crash-stats.mozilla.com/report/index/bp-5c109f7b-7d74-4920-a7c7-ce89b2150823
https://crash-stats.mozilla.com/report/index/bp-a07521aa-a3a2-4110-a229-cc8b52150823
https://crash-stats.mozilla.com/report/index/bp-44653a14-f691-4faa-8fb7-c7ecf2150823


Expected results:

No crash
(Reporter)

Comment 1

3 years ago
Okay, after some testing I found that I had set layers.acceleration.force-enabled to true for testing purposes. After setting this to false the crashes don't happen anymore.
Summary: Firefox crashes on Google+ @ libcairo.so.2.11400.2@0x22630 → Firefox crashes on Google+ @ libcairo.so.2.11400.2@0x22630 with layers.acceleration.force-enabled

Comment 2

3 years ago
All the crash reports lack symbols (is this a distro build?) and the following app notes:
> OpenGL: NVIDIA Corporation -- GeForce GTX 560 Ti/PCIe/SSE2 -- 4.5.0 NVIDIA 352.30 -- 
> texture_from_pixmap GL Layers- libGL.so.1- libGL.so.1+ GL Context- GL Context+ GL Layers+
Crash Signature: [@ libcairo.so.2.11400.2@0x22630 ]
Component: Untriaged → Graphics
Keywords: crash
Product: Firefox → Core
There have been zero reports of this crash recently in the last month. Jonathan, is this still reproducible for you?
Flags: needinfo?(jonathan_haas)
Whiteboard: [gfx-noted]
(Reporter)

Comment 4

3 years ago
Yes, I'm using the Fedora distro builds, and no, I can't reproduce it anymore with the 41.0.2 Fedora build.

I'm closing this for now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jonathan_haas)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.