Closed Bug 1197624 Opened 5 years ago Closed 3 years ago

Bookmarks toolbarbutton doesn't have dropmarker when toolbar is in "overflow" mode

Categories

(Firefox :: Theme, defect)

40 Branch
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox40 --- wontfix
firefox41 --- wontfix
firefox42 --- wontfix
firefox43 --- wontfix
firefox48 --- wontfix
firefox49 --- wontfix
firefox-esr38 --- unaffected
firefox-esr45 --- wontfix
firefox50 --- wontfix
firefox51 --- wontfix
firefox52 --- fix-optional
firefox53 --- fix-optional
firefox54 --- fix-optional

People

(Reporter: arni2033, Unassigned)

References

Details

(Keywords: regression)

Attachments

(2 files)

STR:   (Win7, Nightly 43.0a1 (2015-08-20))
1. Place Bookmarks button button on toolbar.
2. Dock the window to the left side of screen, place mouse over right border of the window and drag it to the left to make window's width as small as possible (to cause overflow)
3. Click #nav-bar-overflow-button to view hidden buttons in toolbar

Result:       Bookmarks button has no dropmarker.
Expectations: Bookmarks button has a dropmarker, like it used to.
Component: Menus → Theme
Pushlog:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=62478b47bc14&tochange=87f15ce8266d

Regressed by:
87f15ce8266d	Dão Gottwald — Bug 1147702 - Use a @2x Toolbar.png on Windows for basic hidpi support. r=MattN
Blocks: 1147702
Version: Trunk → 40 Branch
Flags: needinfo?(dao)
Duplicate of this bug: 1220677
I can see this issue on Windows10, but not on Linux.
This is caused by
https://dxr.mozilla.org/mozilla-central/source/browser/themes/windows/customizableui/panelUIOverlay.css#87
>.widget-overflow-list .toolbarbutton-1 > .toolbarbutton-menubutton-dropmarker > .dropmarker-icon {
>  padding: 0 6px;
>}
(introduced with bug 916953 fix)
and
https://dxr.mozilla.org/mozilla-central/source/browser/themes/windows/browser.css#686
>#bookmarks-menu-button[cui-areatype="toolbar"] > .toolbarbutton-menubutton-dropmarker > .dropmarker-icon {
>  max-width: 18px;
>}
(originally introduced with bug 1147702 fix)
These styles result 18-(6*2)=6px size icon...

For about the toolbar(navigation bar), there is another style.
https://dxr.mozilla.org/mozilla-central/source/browser/themes/windows/browser.css#752
>#nav-bar #bookmarks-menu-button[cui-areatype="toolbar"] > .toolbarbutton-menubutton-dropmarker > .dropmarker-icon {
>  /* horizontal padding + border + actual icon width */
>  max-width: 32px;
>}

For about Linux not having this issue, there is no "padding: 0 6px".
https://dxr.mozilla.org/mozilla-central/source/browser/themes/linux/customizableui/panelUIOverlay.css

Workarounds with Stylish add-on:
.widget-overflow-list .toolbarbutton-1 > .toolbarbutton-menubutton-dropmarker > .dropmarker-icon {
  padding: 0 !important;
}
Or
#bookmarks-menu-button[cui-areatype="toolbar"][overflowedItem=true] > .toolbarbutton-menubutton-dropmarker > .dropmarker-icon {
  max-width: 32px;
}
Or
#bookmarks-menu-button[cui-areatype="toolbar"] > .toolbarbutton-menubutton-dropmarker > .dropmarker-icon {
  max-width: 32px !important;
}
Or
?
Duplicate of this bug: 1255492
Duplicate of this bug: 1295020
This is a long outstanding issue. How about next steps ?
Gijs, do you know who could help with this? Thanks
(In reply to Sylvestre Ledru [:sylvestre] from comment #8)
> Gijs, do you know who could help with this? Thanks

Talking to Dão would be a good first step. I don't have cycles to work on this myself, and he's been needinfo'd here for a while and was also the person who wrote the patch for the regressing bug.
Flags: needinfo?(gijskruitbosch+bugs)
Long time regression, wontfix for 49 at this point. I will email Dão today.
Marking fix-optional for 50 after talking with Dao.
Mark 51 fix-optional for now but still happy to take the patch in 51 early beta.
This button has been redesigned so this bug can't happen anymore.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(dao+bmo)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.