Closed Bug 1197639 Opened 4 years ago Closed 2 years ago

Installer hangs when using non standard Users/installer folder in Windows 10

Categories

(Firefox :: Installer, defect)

40 Branch
x86_64
Windows 10
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: neil, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.135 Safari/537.36 Edge/12.10240

Steps to reproduce:

Installing Firefox from Firefox Setup 40.0.2 on a windows 10 10240.

Note: I have changed my default path for the Documents/Desktop/Downloads folder from the default on C: to a bespoke folder on D:. This may not be relevant, but just thought I'd point it out.
I also installed firefox to the D drive at D:\Program Files (x86)\Mozilla Firefox.
Also running Bitdefender Internet security 2015, but no error messages or warnings


Actual results:

Hangs when attempting to put a link to the desktop, which it seems to try putting in C:\programdata\Microsoft\Windows\StartMenu\Programs\Mozilla Firefox.lnk. Just hangs there, menacingly doing nothing. No links were created. A reinstall shows a repair option, and firefox exists in the folder.


Expected results:

Links should have been created and installer should have completed and closed cleanly. As such, I am unsure whether it is completely installed, or whether anything else should have been done after the hanging point.
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Summary: Installer hangs when using non standard Users folder in Windows 10 → Installer hangs when using non standard Users/installer folder in Windows 10
Component: Untriaged → Installer
Summary: Installer hangs when using non standard Users/installer folder in Windows 10 → Installer hangs when using non standard Users folder in Windows 10
Summary: Installer hangs when using non standard Users folder in Windows 10 → Installer hangs when using non standard Users/installer folder in Windows 10
Attached image image of issue
Blocks: 1176506
Blocks: windows-10
No longer blocks: 1176506
CC'ing QA for testing on Win 10. Maybe another Win 10 bug in the install process.
Flags: needinfo?(andrei.vaida)
I was unable to reproduce this issue on Windows 10 Pro x64 Builds 10240 and 10525, using Firefox 40.0.2 (20150812163655) with the steps from Comment 0. Firefox installed correctly, with no hangs or errors.


Neil-- could you please let me know what kind of Windows account you are using? That's Local Account or Microsoft Account. Also, do you have Administrator rights for that account?

Another thing you might look at is whether you have read/write permissions for that specific filepath for which you're encountering the hang: "C:\programdata\Microsoft\Windows\StartMenu\Programs\".
Flags: needinfo?(andrei.vaida) → needinfo?(neil)
A Microsoft account, full privileges. Nothing else has had a problem installing. This was a clean install of windows 10 a month ago. I have multiple applications installed, visual studio, java, Ms office, and a lot of others.
Flags: needinfo?(neil)
(In reply to neil from comment #4)
> A Microsoft account, full privileges. Nothing else has had a problem
> installing. This was a clean install of windows 10 a month ago. I have
> multiple applications installed, visual studio, java, Ms office, and a lot
> of others.

Thanks for taking the time to provide this info, Neil. Could you also let me know the exact Windows 10 version you're using? You can see that either by pressing [Windows] key + [Pause] key or by: searching for "System Information" → click "System Summary" → "OS Name" and "Version" fields.

I suspect this might be isolated to your current setup since I haven't been able to replicate it on two different test environments, but it might also be something that might have to do with a specific Windows 10 edition.
Flags: needinfo?(neil)
Having exactly the same issue as described by Neil.

windows version use: 10.0.10240 build 10240

As stated by Neil; hangs at creating the lnk file.
Also opt to install Firefox on the d:\ drive instead of the default c:\
(screenshot available on request).

No special applications installed ; but i believe i already installed firefox a few days ago without problem, but today it did seem to have disappeared and could not find it anymore even though i logged in with the same user  (also online microsoft account user with all privileges)
Closing out old bugs; please re-file with updated information if this is still a problem.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(neil)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.