Closed Bug 1197642 Opened 4 years ago Closed 3 years ago

Intermittent test_fullscreen-api-race.html | The window should no longer be in fullscreen | Fail to run test openNewWindow, navigate

Categories

(Core :: DOM: Core & HTML, defect, P3)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox43 --- affected

People

(Reporter: xidorn, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure)

Attachments

(1 obsolete file)

In bug 1180574, we made the test more robust and less likely to break in this way. But there still exists cases we fail to workaround, which will be tracked in this bug.
Summary: Intermittent test_fullscreen-api-race.html | The window should no longer be in fullscreen → Intermittent test_fullscreen-api-race.html | The window should no longer be in fullscreen | Fail to run test openNewWindow, navigate
Depends on: 1137009
Blocks: 1215369
No longer blocks: fullscreen-api
in working on taskcluster and docker to run the tests, test_fullscreen-api-race.html has a common problem of failing in the mochitest-2 job often:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=899f61b37a6b&filter-searchStr=m%282%29&selectedJob=14977620

both the race and non race versions fail.

this doesn't happen all the time, but 50%+ of the runs.  I want to know if there is some package or configuration of the OS container (in this case docker) which we should do to help ensure success.  This is linux64 we are focusing on- primarily debug.

:xidorn, what can I do to help fix these issues or make it easier for you to reproduce and help us get to 99% green for this test.
Flags: needinfo?(quanxunzhen)
Blocks: 1221659
Not sure whether it really fixes tc mochitest-2 job (because I failed to trigger tc tasks on my try push with the syntax present in the try push in comment 95), but I guess it should.

It looks good in my try push in comment 96 anyway.
Flags: needinfo?(quanxunzhen)
Errr, wait... the patch is not for this bug, but for bug 1200092... I think it should fix almost all intermittents on this test, though.
No longer blocks: 1221659
Attachment #8703492 - Attachment is obsolete: true
:jmaher, could you test my patch with tc mochitest-2 and see whether it also fixes the issue there?
Flags: needinfo?(jmaher)
this doesn't fix it on docker/tc, but it seems to run fine locally for me.
Flags: needinfo?(jmaher)
Could you provide a way to run the test on tc so that I can debug this? It seems to be a pretty low-frequent intermittent in normal try push nowadays, so I feel it may need far more resources to reproduce in normal way.
Flags: needinfo?(jmaher)
I have a hard time reproducing locally in the docker container- I think if we are getting this fixed for the current automation then we are winning.  I will continue to look at this as we get our other bugs fixed and look for any patterns.

Sorry for the slight randomization.
Flags: needinfo?(jmaher)
I'm removing the dependency on this bug as I'm not seeing this intermittent issue happening on the on-going work of running tests jobs on TC/docker.
If we see it again we will let you know.

For the record, the OF robot comments are *only* related to the jobs running on Buildbot.
No longer blocks: tc-linux64-debug
Bulk assigning P3 to all open intermittent bugs without a priority set in Firefox components per bug 1298978.
Priority: -- → P3
It doesn't happen for over half year. Close as WORKSFORME.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.