GC Markers can collapse strangely

RESOLVED FIXED in Firefox 43

Status

RESOLVED FIXED
3 years ago
4 months ago

People

(Reporter: jsantell, Assigned: jsantell)

Tracking

41 Branch
Firefox 43
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox43 fixed)

Details

Attachments

(3 attachments)

Created attachment 8651559 [details]
Screen Shot 2015-08-23 at 10.32.29 AM.png

Uncovered this while doing allocation things, and I think it's recreatable outside of the patch. View attached image. The restyle/paint markers should be between GC markers, except a good chunk of them are collapsed under the last one.
(Assignee)

Updated

3 years ago
Blocks: 1159048, 1191480
Created attachment 8651560 [details]
weird-gc-collapse.json

json recording.
Created attachment 8651566 [details] [diff] [review]
1197646-marker-order.patch

This was a fun one.

Now we sort markers on the client upon completion -- the server side still does for consistency, and we'd change this whenever we do non-realtime markers as well.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=d265980af54a
Attachment #8651566 - Flags: review?(vporof)
Comment on attachment 8651566 [details] [diff] [review]
1197646-marker-order.patch

Review of attachment 8651566 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/devtools/server/actors/performance-recording.js
@@ +237,5 @@
>        this._profile = form.profile;
>      }
> +
> +    // Sort again on the client side if we're using realtime markers and the recording
> +    // just finished. This is because GC markers can come into the array out of order with

Not just GC markers, this can happen with anything. For example, Composite markers will have this issue too.
Attachment #8651566 - Flags: review?(vporof) → review+
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1189628
https://hg.mozilla.org/mozilla-central/rev/7479b25812d1
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox43: --- → fixed
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.