[NEWS] need to display nntp server messages

VERIFIED FIXED in M11

Status

defect
P3
normal
VERIFIED FIXED
20 years ago
3 years ago

People

(Reporter: lchiang, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

We need to display imap server error and status messages to the user. Also see
bug 6651 which provides more detail.  I'm entering a new bug, separate from
6651, to track News.
Status: NEW → ASSIGNED
Summary: need to display nntp server messages → [NEWS] need to display nntp server messages
Target Milestone: M11
accepting.

marking m11.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
this bug is related to bug #8362

if the server sends back an error message, it will turn into an alert.

for example, try posting to a non-existant news group.

I've hooked up the basics (there is still more to do) of progress and status as
well.

when downloading articles, watch the progress bar and status area.

there is more status / progress work to be done, and there are bugs, but this
bug is fixed.

marking fixed.
QA Contact: lchiang → huang
qa contact to Karen
Refer to bug#6651, still wait for the messaging server 3.x is available for
verifying this bug.
Lisa & Seth,

Isn't this bug duplicate of bug#8362?

I already verified on bug#8362 that there was a warning dialog "A New (NNTP)
error occurred: No such group" displayed.

Any warning message else that I need to verify for this bug?
Lisa, can you tell me any other warning message that I need to verify?
Otherwise, I am going to mark as verified based on the fixed for bug#8362.
Go ahead and verify for the warning in the other bug.  I don't have a listing of
all the errors that a news server can return.

Actually, I do have one. Try to post to a newsgroup which is in a news server
that's not your default news server.
1)  From your Inbox, compose new message
2)  Type in a name (for recipient) of a newsgroup that you have subscribed on a
news server that is not your default.
3)  Send
4)  You should get an NNTP error back.
Status: RESOLVED → VERIFIED
Linux 12-06-08-M12 (Used today's build single profile)
WinNT 12-06-09-M12 (Used today's build single profile)
Mac 12-02-12-M12 (Used 12/2 more stable build)

Based on Seth for retesting on non-existing newsgroup:
got an error display: "A New (NNTP) error occurred: No such group".

Based on Lisa for retesting on sending to nondefault/existing newsgroup:
got an orror: "A News (NNTP) occured: 437 Unwanted newsgroup
"[nondefault/nonexisting_newsgroup_name]" -> OK -> "Sending of message failed"
displayed. Mark as Verified.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.