Closed Bug 1197738 Opened 6 years ago Closed 5 years ago

[Contacts] When you add a picture into contact, the text "select from" appears at the bottom

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master fixed)

RESOLVED FIXED
FxOS-S6 (04Sep)
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- fixed

People

(Reporter: huxiaoyan, Assigned: etienne)

Details

(Keywords: regression, Whiteboard: [2.5-aries-test-run-1])

Attachments

(16 files)

[1.Description]:
[Aries kk v2.5][Flame kk v2.5][Contact] When you add a picture as contact portrait using Camera or Gallery,the text  "select from" flicks across screen and disappear at the bottom .

Found Time: 02:42
See attachment : logcat_0242.txt  & Aries_kk_v2.5.3gp (at 00:18) & AriesKK_v2.5.png

[2.Testing Steps]: 
1.Launch Contact ->create a new contact.
2.Tap add picture.
3.Select Camera or Gallery.

[3.Expected Result]: 
3.The text "select from" should not appear at  the bottom.

[4.Actual Result]:
 3.The text  "select from" flicks across screen and disappear at the bottom .

[5.Reproduction build]: 
Device: Arise KK 2.5 (Affected)
Build ID               20150823221817
Gaia Revision          cddb9f610cbe03d0ca39d81bbdce46a0fca841ab
Gaia Date              2015-08-23 03:34:38
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4ccdd06e51d7209ba429196df7cab97bf66962db
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150823.214038
Firmware Date          Sun Aug 23 21:40:46 UTC 2015
Firmware Version       v18D v4
Bootloader             s1

Device: Flame KK 2.2 (Unaffected)
Build ID               20150823032504

Gaia Revision          335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46

Gaia Date              2015-08-14 19:06:41

Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1effc4cb6414

Gecko Version          37.0

Device Name            flame

Firmware(Release)      4.4.2

Firmware(Incremental)  eng.cltbld.20150823.065101

Firmware Date          Sun Aug 23 06:51:12 EDT 2015

Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.5 (Affected)
Build ID               20150823150207
Gaia Revision          cddb9f610cbe03d0ca39d81bbdce46a0fca841ab
Gaia Date              2015-08-23 03:34:38
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4ccdd06e51d7209ba429196df7cab97bf66962db
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150823.184539
Firmware Date          Sun Aug 23 18:45:51 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
When you add an attachemnt in Messages app, the bug also exits.
It seems like the transition is less smooth. Annabelle, could you attach a video of Flame 2.2 so we can compare how the transition was?
Flags: needinfo?(huxiaoyan)
Attached video Flame_kk-v2.2.3gp
Hi Johan,
  Please reference the Flame_kk-v2.2.3gp. If you have any questiom,please contact me.thanks.
Flags: needinfo?(huxiaoyan)
[Blocking Requested - why for this release]: Visual regression that makes a high-end device more jittery than the Flame.

I'm suspecting a Gecko regression in "Panning and Zooming". Etienne, could you confirm it?
blocking-b2g: --- → 2.5?
Component: Gaia::Contacts → Gaia::System::Window Mgmt
Flags: needinfo?(etienne)
Regression defect. Blocks 2.5
blocking-b2g: 2.5? → 2.5+
I don't understand this bug.
Looking at the videos frame by frame it looks like the animation is playing correctly.

We can raise the issue to the UX team and maybe move to a fade transition but I don't think anything wrong with the current implementation/performance.
Flags: needinfo?(etienne)
I just talked to Etienne. It might be related to the fact that the home button is present. Annabelle, could you take a video of the STR with:
* An Aries with the software home button disabled (you activate home gesture)
* A Flame that has software home button enabled?
Flags: needinfo?(huxiaoyan)
Hi Johan,

   This bug still can be repro on latest Flame KK v2.5 and Aries KK v2.5 by the two situations in comment 8. Please see attachment 'Flame2.5_enableSHB.3gp', 'Aries2.5_disabledSHB.3gp' and 'logcat_0216_Aries_v2.5(disabledSHB).txt'. Thanks.
Flags: needinfo?(huxiaoyan) → needinfo?(jlorenzo)
Attached video Flame2.5_enableSHB.3gp
QA Whiteboard: [MGSEI-Triage+]
After taking a closer look at the new videos posted, it seems you're right. On Flame with SHB, the title of the activity remains for a split second; but not on Aries without. Is it something we can fix on the Gaia side?
Flags: needinfo?(jlorenzo) → needinfo?(etienne)
Assignee: nobody → etienne
Flags: needinfo?(etienne)
Attachment #8655989 - Flags: review?(apastor)
Comment on attachment 8655989 [details] [review]
[gaia] etiennesegonzac:bug-1197738 > mozilla-b2g:master

LGTM. Thanks!
Attachment #8655989 - Flags: review?(apastor) → review+
https://github.com/mozilla-b2g/gaia/commit/3c68cb33f23b8a85271d3243a53ba1a5ddb9b681
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S6 (04Sep)
Hi Annabelle,

Please help to verify this bug, thanks.
Flags: needinfo?(huxiaoyan)
Keywords: verifyme
Flags: needinfo?(huxiaoyan)
Keywords: verifyme
This bug has been verified as "fail" on the latest build of Flame KK 2.5 and Aires KK 2.5 by the STR in comment 0.

Actual results: The "Select from:" animation flickers across screen and then disappear at the bottom.

See attachment: Flame_2.5_EnableSHB.3gp & Flame_2.5_EnableSHB.png & logcat_0833_Flame_2.5_EnableSHB.txt and Flame_2.5_DisableSHB.3gp & Flame_2.5_DisableSHB.png.
Reproduce rate: 10/10


Device: Flame KK 2.5 (Fail)
Build ID               20150905150219
Gaia Revision          03be7d8918bed58c92a40bba211bbbc97a0e516a
Gaia Date              2015-09-04 11:56:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/139446daedab3d00b9f0faba25e1e82191c8c8d1
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150905.183746
Firmware Date          Sat Sep  5 18:38:03 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (Fail)
Build ID               20150905112803
Gaia Revision          03be7d8918bed58c92a40bba211bbbc97a0e516a
Gaia Date              2015-09-04 11:56:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/139446daedab3d00b9f0faba25e1e82191c8c8d1
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150905.105729
Firmware Date          Sat Sep  5 10:57:37 UTC 2015
Bootloader             s1
Attached video Flame_2.5_EnableSHB.3gp
Attached image Flame_2.5_EnableSHB.png
Hi Etienne,

    Could you help to confirm above results in comment 17? It seems this bug has not fixed.

Thank you very much.
Flags: needinfo?(etienne)
(In reply to Annabelle from comment #23)
> Hi Etienne,
> 
>     Could you help to confirm above results in comment 17? It seems this bug
> has not fixed.
> 
> Thank you very much.

It's really hard to see this bug on a video that doesn't have a high frame rate, but I just tested today's master and I can't see it.
Flags: needinfo?(etienne)
sorry had to back this out for making bug 1085667 failures more frequently
Status: RESOLVED → REOPENED
Flags: needinfo?(etienne)
Resolution: FIXED → ---
Comment on attachment 8658106 [details] [review]
[gaia] etiennesegonzac:bug-1197738 > mozilla-b2g:master

This is actually a better fix.
The eventSafety was for 250ms but the transition is 300ms long!
And also switching the position too early caused the dialog to change size and jump. Should be much better!
Flags: needinfo?(etienne)
Attachment #8658106 - Flags: review?(apastor)
Attachment #8658106 - Flags: review?(apastor) → review+
https://github.com/mozilla-b2g/gaia/commit/a6bd1e15aaf20932ec2baff36b31cf9b790a90c5
Status: REOPENED → RESOLVED
Closed: 6 years ago5 years ago
Resolution: --- → FIXED
Hi Etienne,

    Could you please take a look at the results below again? User still can see the words "Select from:" animation flickering across screen about 0.5 second.

Thank you very much.

------------------------------------------------------------------------------------------------
This bug still been verified as "fail" on the latest build of Flame KK v2.2&2.5 and Aires KK 2.5 by the STR in comment 0.

Actual results: The "Select from:" animation flickers across screen and then disappear at the bottom.
See attachment: logcat_1510.txt and Flame_KK v2.5&2.2.3gp(Left is Flame KK v2.2 and another is Flame KK v2.5 )
Reproduce rate: 10/10


Device: Flame KK 2.5 (Fail)
Build ID               20150914150204
Gaia Revision          f37e8f732e0af961b43e912629c84c9e2ceda55d
Gaia Date              2015-09-14 02:12:38
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/fba4b0cd3823975949765acc0b16b964d1712b75
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150914.182849
Firmware Date          Mon Sep 14 18:29:02 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.2 (Unaffected) 
Build ID               20150914032507
Gaia Revision          7a427e0f8aa6c185a9e22358006b97c19435ca4a
Gaia Date              2015-09-09 13:06:12
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0d9c46d01861
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150914.065302
Firmware Date          Mon Sep 14 06:53:13 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (Fail) 
Build ID               20150915002802
Gaia Revision          f37e8f732e0af961b43e912629c84c9e2ceda55d
Gaia Date              2015-09-14 02:12:38
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ce211c03a51cadee6b45673394ec3cbfd620830f
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150914.234841
Firmware Date          Mon Sep 14 23:48:49 UTC 2015
Bootloader             s1
Flags: needinfo?(etienne)
Attached file logcat_1510.txt
Attached video Flame_KK v2.5& 2.2.3gp
(In reply to Annabelle from comment #31)
> Created attachment 8661113 [details]
> Flame_KK v2.5& 2.2.3gpp

Not sure I can see what's wrong with this video...
Also we confirmed earlier that this was only happening with the Software Home Button activated which is not the case in the video.
Flags: needinfo?(etienne)
You need to log in before you can comment on or make changes to this bug.