CSS2.1 declarations-009 fails

RESOLVED INVALID

Status

()

Core
CSS Parsing and Computation
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: Ms2ger, Unassigned)

Tracking

({regression, testcase})

25 Branch
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Comment 1

3 years ago
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=658e5f8a8daf&tochange=5005e426f324

Regressed by:
0f097f7ae11d	Simon Sapin — Bug 887741 - Allow CSS at-rules in declaration lists. r=dbaron


FYI:
Chrome46 also fails
Blocks: 887741
Keywords: regressionwindow-wanted
Version: unspecified → 25 Branch
CSS Syntax Level 3 invalidates this test with a change proposed in [1] and accepted by the working group in [2]. All list of declarations (including the body of style rules) are parsed with the algorithm at [3] and can also contain at-rules. Even if no at-rules is supported in a given context, this affects error recovery.

[1] https://lists.w3.org/Archives/Public/www-style/2013Apr/0506.html
[2] https://lists.w3.org/Archives/Public/www-style/2013May/0783.html
[3] http://www.w3.org/TR/css-syntax-3/#consume-a-list-of-declarations (using a /TR URL because the ED rendering is broken right now)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(We should probably get the test fixed, though.)
You need to log in before you can comment on or make changes to this bug.