Browser crashes while typing in URL's

RESOLVED DUPLICATE of bug 119521

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 119521
16 years ago
13 years ago

People

(Reporter: Thomas Stromberg, Assigned: asa)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.7+)
Gecko/20020111
BuildID:    2002011108



Reproducible: Sometimes
Steps to Reproduce:
1. Pick a random moment
2. Type a URL that you've been before
3. You might crash

Actual Results:  I tried going to some URL's I'd been to before, and while
typing it, I crashed. Opened up browser again, began typing another, and
crashed. It doesn't always occur, however. 

Expected Results:  Keep displaying the completion, and eventually get to the URL

Here was the second crash:

Date/Time:  2002-01-13 11:44:18 -0500
OS Version: 10.1.2 (Build 5P48)

Command:    Mozilla
PID:        573

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0:
 #0   0x0062d640 in nsTimerImpl::Fire(void)
 #1   0x0062d634 in nsTimerImpl::Fire(void)
 #2   0x0062c6fc in TimerThread::Run(void)
 #3   0x005be018 in nsThread::Main(void *)
 #4   0x0050c09c in 0x50c09c

Thread 1:
 #0   0x7000497c in syscall
 #1   0x70557600 in BSD_waitevent
 #2   0x70554b80 in CarbonSelectThreadFunc
 #3   0x7002054c in _pthread_body

Thread 2:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x705593ec in CarbonOperationThreadFunc
 #3   0x7002054c in _pthread_body

Thread 3:
 #0   0x70044cf8 in semaphore_timedwait_signal_trap
 #1   0x70044cd8 in semaphore_timedwait_signal
 #2   0x7003f2b8 in _pthread_cond_wait
 #3   0x70283ea4 in TSWaitOnConditionTimedRelative
 #4   0x7027d748 in TSWaitOnSemaphoreCommon
 #5   0x702c2078 in TimerThread
 #6   0x7002054c in _pthread_body

Thread 4:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x70250ab0 in TSWaitOnCondition
 #3   0x7027d730 in TSWaitOnSemaphoreCommon
 #4   0x70243d14 in AsyncFileThread
 #5   0x7002054c in _pthread_body

Thread 5:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x7055b884 in CarbonInetOperThreadFunc
 #3   0x7002054c in _pthread_body


PPC Thread State:
  srr0: 0x0062d640 srr1: 0x0000f030                vrsave: 0x00000000
   xer: 0x0000001c   lr: 0x0062d634  ctr: 0x700056fc   mq: 0x00000000
    r0: 0x0062d634   r1: 0x03302c60   r2: 0x00107000   r3: 0x00000000
    r4: 0x03aff980   r5: 0x0010ec78   r6: 0x03293370   r7: 0x00000000
    r8: 0x000507d4   r9: 0x80240e10  r10: 0x00000024  r11: 0x80003710
   r12: 0x700056fc  r13: 0x00000000  r14: 0x00000036  r15: 0x00651990
   r16: 0x006519c0  r17: 0xbfffee90  r18: 0x000645e8  r19: 0x00002707
   r20: 0x00000000  r21: 0x0000001c  r22: 0x70004234  r23: 0x700042c8
   r24: 0x00000004  r25: 0x000006eb  r26: 0x8081ab5c  r27: 0x00061480
   r28: 0x00000000  r29: 0xbfffef00  r30: 0x00000000  r31: 0x00000001

**********

*** This bug has been marked as a duplicate of 119521 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.