certain filters no longer work

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: germano.massullo, Unassigned)

Tracking

38 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150812142102

Steps to reproduce:

I have many e-mail filters, but some of them, ceased to work suddendly (many and many months ago).
I haven't managed to let them work. Yesterday I also tried to erase of on them and create it again, then I tried to clic on "apply filter" but that did not fix the problem.
The account is POP type
(Reporter)

Updated

3 years ago
Summary: certain filters of mine do no longer work → certain filters no longer work

Comment 1

3 years ago
Which "apply filter" menuitem did you use? Can you provide an example of the rules in a non-working filter? The field and the condition ?
(Reporter)

Comment 2

3 years ago
(In reply to :aceman from comment #1)
> Which "apply filter" menuitem did you use?

Tools->Filters-> "Run selected filters to Inbox" + clic on "Run now" button. Translation may be different because I am not using Thunderbird in English language.

(In reply to :aceman from comment #1)
> Can you provide an example of the rules in a non-working filter? The field and the condition ?

- Apply filter when:
* Manually Run
* Getting New Mail: Filter before junk classification

- Satisfies: match any of the following:
From, to, cc or bcc contains: foo@foo.org

- Perform these actions:
Move to foo folder

Comment 3

3 years ago
(In reply to Germano Massullo from comment #2)
> (In reply to :aceman from comment #1)
> > Which "apply filter" menuitem did you use?
> 
> Tools->Filters-> "Run selected filters to Inbox" + clic on "Run now" button.
> Translation may be different because I am not using Thunderbird in English
> language.

Can when you enter the Filters list dialog, can you try to select the folder in the dropdown (even though it appears it is already selected) ? Then click Run now. Does it work then?
(Reporter)

Comment 4

3 years ago
(In reply to :aceman from comment #3)
> (In reply to Germano Massullo from comment #2)
> > (In reply to :aceman from comment #1)
> > > Which "apply filter" menuitem did you use?
> > 
> > Tools->Filters-> "Run selected filters to Inbox" + clic on "Run now" button.
> > Translation may be different because I am not using Thunderbird in English
> > language.
> 
> Can when you enter the Filters list dialog, can you try to select the folder
> in the dropdown (even though it appears it is already selected) ? Then click
> Run now. Does it work then?

No it does not work

Comment 5

3 years ago
The "Run now" only runs the filters that are currently selected in the Filters list (not all). Have you selected all the wanted filters? You can select individual filters with Ctrl and ranges with Shift, as in Windows explorer.
(Reporter)

Comment 6

3 years ago
(In reply to :aceman from comment #5)
> The "Run now" only runs the filters that are currently selected in the
> Filters list (not all). Have you selected all the wanted filters?
Yes I did
(Reporter)

Comment 7

3 years ago
If you need other informations, please ask

Comment 8

3 years ago
Are the filters you want to run "enabled", have the checkbox ticked in the respective column in the filter list?
(Reporter)

Comment 9

3 years ago
(In reply to :aceman from comment #8)
> Are the filters you want to run "enabled", have the checkbox ticked in the
> respective column in the filter list?

Yes
(Reporter)

Comment 10

3 years ago
Actually there are many filters that are not applied by Thunderbird 38.4
I've tried now on Thunderbird 38.5 and works without problem.
Maybe few screen of the rules?
(Reporter)

Comment 12

3 years ago
Created attachment 8709951 [details]
screenshot
I've tried but the problem is not happening, what is the version of your thunderbird
Created attachment 8709953 [details]
is in italian but the field are understable
(Reporter)

Comment 15

3 years ago
(In reply to Daniele "Mte90" Scasciafratte from comment #13)
> I've tried but the problem is not happening, what is the version of your
> thunderbird

38.5.0
This all sounds very odd. 

Just to be clear, this isn't the same issue as bug 1224218?
And does it happen in version 45?
Flags: needinfo?(germano.massullo)
(Reporter)

Comment 17

2 years ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #16)
> And does it happen in version 45?

Filters started working again in new emails, but there are many of the older (unclassified) that still cannot be handled from the filter, even if you trigger it manually
(Reporter)

Updated

2 years ago
Flags: needinfo?(germano.massullo)
perhaps you are seeing bug 1312172?

(but that wouldn't explain why non-manual filter is working)
Flags: needinfo?(germano.massullo)
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #18)
> perhaps you are seeing bug 1312172?
> 
> (but that wouldn't explain why non-manual filter is working)

at this point we need some examples of your filters that are not working
Whiteboard: [closeme 2017-03-15]
(Reporter)

Comment 20

2 years ago
On Thunderbird 45.7.0 I am not experiencing this problem anymore.
You can close the bugreport.
Thank you
Flags: needinfo?(germano.massullo)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2017-03-15]
You need to log in before you can comment on or make changes to this bug.