Last Visited bookmark field always displays blank

VERIFIED FIXED in mozilla1.4alpha

Status

SeaMonkey
Bookmarks & History
P3
normal
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: Luke Koleszar, Assigned: slipszi)

Tracking

({regression, useless-UI})

Trunk
mozilla1.4alpha
x86
All
regression, useless-UI
Bug Flags:
blocking1.3a -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9.7+) Gecko/20020111
BuildID:    2002011103

Sometime around Jan. 3, the Last Visited bookmark field stopped working.

Reproducible: Always
Steps to Reproduce:
1. Open Manage Bookmarks window
2. Turn on "Last Visited" display


Actual Results:  Notice that all bookmarks have a blank Last Visited field

Expected Results:  Last Visited field shows the time and date that the page was
last visited.

Works with 0.9.7
Works with 2002010303

Doesn't work with 2002010403
Doesn't work with 2002011103
(Reporter)

Comment 1

16 years ago
Note that the Last Visited time is remembered correctly with current builds. 
This seems to be only a display problem.

I.E. if you visit a bookmark with 2002011103, then run 0.9.7, the Last Visited
time does correctly reflect the visit just made in 2002011103.
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla1.2

Comment 2

16 years ago
This worked fine in previous releases. It appears that the backend is still
functioning so this shouldn't be too difficult to explore and fix. If we don't
fix this then the column should be removed from the Bookmarks Manager for the
next major releases. 
Keywords: nsbeta1, regression, useless-UI

Comment 3

16 years ago
nsbeta1- per Nav triage team,  ->1.2
Keywords: nsbeta1 → nsbeta1-

Comment 4

16 years ago
Actually, the "last visited" field is displayed in the "added" column.

Comment 5

16 years ago
Same thing with Mac OS 9.1 Build 2002061103

Comment 6

16 years ago
confirming comment #4 "last visited" content appears in "added" field, should be
very easy to fix now
(Assignee)

Comment 7

16 years ago
Created attachment 98615 [details] [diff] [review]
Patch to fix the bug

Added a patch to fix the bug and to display the last modified date correctly as
well.

Comment 8

15 years ago
just for the notes:
this bug needs a new traget ...
the bug lies not within the viewer
the data is saved to the wrong field in bookmarks.html
(Assignee)

Comment 9

15 years ago
> this bug needs a new traget ...

Agreed. Since this is a trivial fix, perhaps it could be mozilla1.2beta? Well, I 
guess it really depends on when will Ben have time for this.

> the bug lies not within the viewer
> the data is saved to the wrong field in bookmarks.html

No, the problem *is* with the viewer:

1. The order of the columns in the column definition of the bookmark tree is not 
the same as the order of cells in the body of the tree
2. The label of the Last Modified Date has changed from NC-rdf to WEB-rdf, but 
bookmarks.xml still uses NC-rdf

These two errors are corrected in the patch that is attached to this bug.
(Assignee)

Comment 10

15 years ago
Created attachment 102665 [details] [diff] [review]
Updated patch to fix the bug

Updated patch for the latest version (1.47) in the trunk
Attachment #98615 - Attachment is obsolete: true

Updated

15 years ago
Keywords: mozilla1.3, patch

Updated

15 years ago
Keywords: review

Updated

15 years ago
Flags: blocking1.3a?
Target Milestone: mozilla1.2alpha → ---

Updated

15 years ago
Flags: blocking1.3a? → blocking1.3a-

Updated

15 years ago
Attachment #102665 - Flags: review?
try asking the review of a specific person, I think jag
(jaggernaut@netscape.com) would be good for fixes in this area.

Comment 12

15 years ago
*** Bug 193920 has been marked as a duplicate of this bug. ***

Comment 13

15 years ago
*** Bug 146534 has been marked as a duplicate of this bug. ***
*** Bug 197609 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Blocks: 196756

Comment 15

15 years ago

*** This bug has been marked as a duplicate of 124819 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 16

15 years ago
sorry, I haven't noticed thar there is a patch attached.
Can I take it and check into the bookmarks branch ?
(Assignee)

Comment 17

15 years ago
Created attachment 117535 [details] [diff] [review]
Patch diffed against the latest tree

Althogh the patch is trivial, I still do not have r= or sr= for it. If you can
check it in anyway, please, do it.
(Assignee)

Updated

15 years ago
Attachment #102665 - Attachment is obsolete: true
(Assignee)

Updated

15 years ago
Attachment #117535 - Flags: review?(slipszi)
(Assignee)

Updated

15 years ago
Attachment #117535 - Flags: review?(slipszi) → review?(jaggernaut)

Comment 18

15 years ago
sorry for not letting you know, this is already fixed on the branch we are
working on, so you don't have to request a review for this.

Comment 19

15 years ago
reopening, since this bug has a patch
Status: RESOLVED → REOPENED
OS: Windows ME → All
Resolution: DUPLICATE → ---
Target Milestone: --- → mozilla1.4alpha

Comment 20

15 years ago
-> Silvester
Assignee: ben → slipszi
Status: REOPENED → NEW

Comment 21

15 years ago
Using the 2003-03-25-03 Mach0 and 2003-03-25-04 Win32 trunk builds, The last
visited  field is now providing the correct time on when that bookmark was
previously loaded.

Updated

15 years ago
Attachment #117535 - Flags: superreview?(alecf)
Attachment #117535 - Flags: review?(varga)
Attachment #117535 - Flags: review?(jaggernaut)

Comment 22

15 years ago
I probably caused a confusion here. This is fixed on the trunk by big bookmarks
landing on Monday.

Comment 23

15 years ago
OK, this looks fine now. Marking verified.
Status: NEW → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED

Comment 24

15 years ago
Comment on attachment 117535 [details] [diff] [review]
Patch diffed against the latest tree

ooh, that's easy. sr=alecf
Attachment #117535 - Flags: superreview?(alecf) → superreview+

Comment 25

15 years ago
Verified.
Status: RESOLVED → VERIFIED

Updated

15 years ago
Attachment #117535 - Flags: review?(varga)
Attachment #102665 - Flags: review?
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.