Calendar disappeared. Only trace is in about:config.

RESOLVED WORKSFORME

Status

Calendar
General
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Dan Dreifort, Unassigned)

Tracking

Lightning 4.0.2
x86_64
Windows 7

Details

(Whiteboard: [lightning not automatically installed])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8651928 [details]
thunderbird-calendar-about-config.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150812163655

Steps to reproduce:

Launch Thunderbird 38.2.


Actual results:

It's gone. My calendar tab disappeared. ...So did all of the relevant menu items to bring it back, like "show Today pane" "show calendar" etc. (Just doing those from memory, so they're probably not verbatim what used to be there.)
There's also no mention of calendar in the options window.
The only local proof that I'm not delusional (I swear I used to have a calendar!) is the two dozen calendar entries in about:config. Screenshot of that, here http://i.imgur.com/KGUY77k.png (and attached to bug report)
The calendar keyboard shortcuts also don't work.
I should note that I've already uninstalled and reinstalled TB, to no avail.
Windows 7, fully updated, running on a beefy machine.


Expected results:

Calendar tab should be there. If not, menu and/or keybd shortcuts could bring it back. Alas, not my lucky day.
(Reporter)

Updated

2 years ago
Summary: Calendar dissappeared. Only trace in in about:config. → Calendar dissappeared. Only trace is in about:config.
(Reporter)

Updated

2 years ago
Summary: Calendar dissappeared. Only trace is in about:config. → Calendar disappeared. Only trace is in about:config.
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
(Reporter)

Comment 1

2 years ago
That was quick. I was under the impression that Lightning was now integrated into TB. Poking around a bit, I found that Lightning still exists as an addon. Downloaded 4.0.2 and installed it. Calendar back. Easy. Wonder why it uninstalled.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID

Comment 2

2 years ago
In general, this is a valid report, because it shouldn't have disappeared after TB update. Installing from AMO is just a workaround.

From which version did you update to TB 38.2? Was Lightning completely uninstalled or still visible but disabled in the add-ons manager?

Based on the config screenshot, you use the default Home calendar and a Google calendar using the Google provider, correct? Has this been uninstalled, too, or just disabled when updating to TB 38.2?

Are there any other noteworthy infromation about your installation like not common profile locations, running the installation with administrator priviledges, installation via software distribution etc.?
Status: RESOLVED → REOPENED
Component: Untriaged → General
Ever confirmed: true
Flags: needinfo?(bugzilla)
Product: Thunderbird → Calendar
Resolution: INVALID → ---
Whiteboard: [lightning not automatically installed]
Version: 38 → Lightning 4.0.2
(Reporter)

Comment 3

2 years ago
99% sure I did not manually update, so it was almost certainly incremental from whatever was the previous release.

I neither uninstalled nor disabled Lightning prior to the upgrade.

I do not "use" the Google calendar, though apparently I haven't totally removed it from config. Deprecated years ago. I do not see it in the sidebar, where I only see:
Calendar
[x] Home
(Long ago, the other calendar used to show up here too, but it's been years since I used it.)

Profile is not on the OS SSD, but is on a data SSD, other than that, file locations are pretty standard, I think.

Of note: I found a thread wherein many other people had this same problem. 
https://support.mozilla.org/en-US/questions/1078257

You might post there to ask for additional information.

Let me know if you need anything else.
Flags: needinfo?(bugzilla)

Comment 4

2 years ago
This may have been another report for the sync issue in bug 1211160, fixed for TB 38.6.0 - do you still expirience this bug for that recent version?
Flags: needinfo?(bugzilla)
(Reporter)

Comment 5

2 years ago
 I re-installed lightning and never had this problem again.
Flags: needinfo?(bugzilla)

Comment 6

2 years ago
Thanks. Resolving WFM as per comment 5.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.