Closed Bug 1198059 Opened 4 years ago Closed 4 years ago

keyboard settings no longer stick

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-master verified)

VERIFIED FIXED
Tracking Status
b2g-master --- verified

People

(Reporter: dietrich, Assigned: kgrandon)

Details

(Keywords: regression)

Attachments

(1 file)

STR:

1. go to settings of built-in keyboard
2. change any or all of them
3. exit those settings
4. re-enter those settings

The changes are lost.

Aries, dogfood-latest channel.
QA Contact: lixia
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame KK 2.5
Build ID               20150813082739
Gaia Revision          243582cc1366299f2e02d3eff08a6be6d9d103d9
Gaia Date              2015-08-13 14:52:45
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/05319307a1142325eadba4b6bca0672ca1847b3f
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150814.182934
Firmware Date          Fri Aug 14 18:29:46 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Environmental Variables:
Device: Flame KK 2.5
Build ID               20150813084739
Gaia Revision          025b83e444ed2c6e8b12a141b452d441f2a845b4
Gaia Date              2015-08-13 15:23:48
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/32d215d2aafec66fdac54b5019552bb3f5bb22cf
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150814.182934
Firmware Date          Fri Aug 14 18:29:46 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES repro
Gaia Revision          025b83e444ed2c6e8b12a141b452d441f2a845b4
Gecko Revision         05319307a1142325eadba4b6bca0672ca1847b3f

First Broken Gecko & Last Working Gaia - issue DOES NOT repro
Gaia Revision          243582cc1366299f2e02d3eff08a6be6d9d103d9
Gecko Revision         32d215d2aafec66fdac54b5019552bb3f5bb22cf


Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/243582cc1366299f2e02d3eff08a6be6d9d103d9...025b83e444ed2c6e8b12a141b452d441f2a845b4


Possibly caused by Bug 1193618.
QA Whiteboard: [MGSEI-Triage+]
Hi Kevin,

This bug is probably caused by Bug 1193618, could you help to check?  

Thanks.
Flags: needinfo?(kevingrandon)
Oops, my fault. This needs a test it seems.
Assignee: nobody → kevingrandon
Status: NEW → ASSIGNED
Flags: needinfo?(kevingrandon)
Comment on attachment 8652650 [details] [review]
[gaia] KevinGrandon:bug_1198059_keyboard_settings > mozilla-b2g:master

Hi Tim,

Sorry about the regression. Here's a fix which adds an assertion that should prevent this from regressing in the future. Please take a look when you have time.
Attachment #8652650 - Flags: review?(timdream)
Comment on attachment 8652650 [details] [review]
[gaia] KevinGrandon:bug_1198059_keyboard_settings > mozilla-b2g:master

Thanks for adding the Gij test!
Attachment #8652650 - Flags: review?(timdream) → review+
Thanks for the review!

In mater: https://github.com/mozilla-b2g/gaia/commit/7e36fb3976bc8aab4ef7cbb37e6c79145b3d4717
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aires KK 2.5 by the STR in comment 0.

Actual results: The keyboard settings can be set/checked successfully.
See attachment: verified_FlameKK_v2.5.3gp
Reproduce rate: 0/10


Device: Flame KK 2.5 (Pass)
Build ID               20150827150209
Gaia Revision          d784c81961d82cbe9e111405468c590a8345856c
Gaia Date              2015-08-27 12:29:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ca086f9ef8bca2d6cdfa79bfc4c854f56a59859e
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150827.190412
Firmware Date          Thu Aug 27 19:04:26 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5(Pass)
Build ID               20150827170125
Gaia Revision          d784c81961d82cbe9e111405468c590a8345856c
Gaia Date              2015-08-27 12:29:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ca086f9ef8bca2d6cdfa79bfc4c854f56a59859e
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150827.162303
Firmware Date          Thu Aug 27 16:23:10 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.