Panning sometimes freezes for seconds, sometimes blank

NEW
Unassigned

Status

()

Firefox for Android
Toolbar
2 years ago
2 years ago

People

(Reporter: glandium, Unassigned)

Tracking

40 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
I got a Nexus 5 last week and installed Firefox (release) on it. I haven't tried beta/aurora/nightly.

Regularly, scrolling vertically (I think that mostly happens on wikipedia, but I haven't visited that many sites, so maybe it's because of that rather than being wikipedia-specific) would kind of freeze. The UI would correctly respond to the vertical scrolling by showing/hiding the urlbar, but the content would not move. After a few long seconds, content would update.

Sometimes, scrolling does happen, but tiles are not showing up and for a few long seconds, I'm left with a blank screen.
When you see this, does the scrollbar still move in response to your finger?
(Reporter)

Comment 2

2 years ago
I can't tell because ever since I've tried reproducing it to answer your question, it hasn't happened. That said, it's happened on sites other than wikipedia yesterday, after I filed the bug.
(Reporter)

Comment 3

2 years ago
So, 10 days later, I've had it happen a few times, but most of the time now, it's less severe (in duration), but still noticeably annoying. Unfortunately, most of the time, I'm panning with my right thumb, hiding the scroll indicator in the process, so it took me a while to both reproduce *and* be able to see it. But now I can finally say: the scroll indicator doesn't show up when panning is frozen but the urlbar shows/hides.
I can also say it tends to happen more when there are multiple tabs.
I also /think/ my phone has really slow I/O and that it's probably a factor.
Hm. This means the compositor thread is blocked, most probably because of large transactions. I was suspecting my recent change to the DynamicToolbarAnimator but now I realize you said it happens on release when my change is only currently on nightly.

At this point I think the only way forward is to get a profile of the issue that includes the compositor thread, but that's going to be hard to do unless you can reproduce this on demand.
You need to log in before you can comment on or make changes to this bug.