Closed Bug 1198200 Opened 5 years ago Closed 2 years ago

[browser] Fix eslint errors

Categories

(Firefox OS Graveyard :: Gaia::TV, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: yifan, Unassigned)

References

Details

(Whiteboard: [ft:conndevices])

The eslint errors of the browser app is temporarily disabled. Have to fix these errors and remove the file path from build/eslint/xfail.list.
No longer blocks: 1156633, 1190158, 1196624, 1198099, 1198103, 1198115
Depends on: 1199563
No longer depends on: 1199563
See Also: → 1156635
Whiteboard: [ft:conndevices][partner-blocker] → [ft:conndevices]
Depends on: 1200078
No longer depends on: 1200078
I have noticed that you added most of the js files in tv_apps/browser/js to xfail.list, because of an eslint error.
I have fixed the error in the eslint plugin with this commit (https://github.com/mozfreddyb/eslint-plugin-no-unsafe-innerhtml/pull/5).

(We still need to wait for gaia to take a more recent version of eslint and eslint-plugin-no-unsafe-innerhtml before this can move on. I will do this in a separate bug and make it block this one)
Btw, with eslint being fixed it will produce a lot of errors about unsafe assignments to innerHTML: I recommend changing them to .textContent-assignments wherever possible.

If it is not possible, you can look in to the sanitizer.js in shared/. I'm happy to help with any questions that may come up around that in the future.
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.