Closed Bug 1198280 Opened 7 years ago Closed 6 years ago

Flash display bug

Categories

(Core :: Plug-ins, defect)

40 Branch
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox40 --- disabled
firefox41 + wontfix
firefox42 --- affected
firefox43 --- affected
firefox-esr38 --- unaffected

People

(Reporter: a_plancher, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [dupe me])

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150812163655

Steps to reproduce:


Hello,

Since upgrade to Firefox 40, my website in Flash doesn't display properly some pages (i.e. : http://www.ap-prod.net/#/clients). You can see it during less than a second, and then it is "erased" by a white page. This doesn't occur with IE, Chrome and Safari. Neither previous Firefox versions before 40.

This is a big problem for all my customers.

Hoping a fix from you.

Thank you.


Actual results:


Hello,

Since upgrade to Firefox 40, my website in Flash doesn't display properly some pages (i.e. : http://www.ap-prod.net/#/clients). You can see it during less than a second, and then it is "erased" by a white page. This doesn't occur with IE, Chrome and Safari. Neither previous Firefox versions before 40.

This is a big problem for all my customers.

Hoping a fix from you.

Thank you.


Expected results:


Hello,

Since upgrade to Firefox 40, my website in Flash doesn't display properly some pages (i.e. : http://www.ap-prod.net/#/clients). You can see it during less than a second, and then it is "erased" by a white page. This doesn't occur with IE, Chrome and Safari. Neither previous Firefox versions before 40.

This is a big problem for all my customers.

Hoping a fix from you.

Thank you.
[Tracking Requested - why for this release]: regression since Firefox40

dom.ipc.plugins.asyncInit = false seems to fix the problem
Status: UNCONFIRMED → NEW
Component: Untriaged → Plug-ins
Ever confirmed: true
Keywords: regression
Whiteboard: [dupe me]
Thank you very much. Do you think this will be fixed for next release?
Duplicate of this bug: 1198277
We should verify that this is fixed in the next 41 beta.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: qe-verify+
Resolution: --- → DUPLICATE
Duplicate of bug: 1194600
The issue is still reproducible with Firefox 41 beta 5 under Win 7 64-bit and Mac OS X. Setting the pref to false fixes this.

The error in the web console is: TypeError: swfmacmousewheel is null www.ap-prod.net:101:13, but it is displayed also when the pref is set to false.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Flags: needinfo?(aklotz)
Reproduced on Firefox41.0b5 with new profile.

And Reproduced on Aurora42.0a2 and Nightly43.0a1 with/without e10s if set  dom.ipc.plugins.asyncInit = true .
Monitoring the network accesses of that page, I notice that when asyncInit = true, button.xml and diapo_Clients.xml are loaded twice.

(button.xml is returning 404 not found by the way)

Are there scripts in your flash content that control the loading of those files? Is there anything that you can tell me about how those files are loaded?
Flags: needinfo?(aklotz) → needinfo?(a_plancher)
Also, when I run it under the Flash Player debugger with asyncInit, I see this:

TypeError: Error #1088: The markup in the document following the root element must be well-formed.
	at BannerRotator_fla::Menu_13/SetButton()
	at BannerRotator/SetOptions()
	at MethodInfo-153()
	at flash.events::EventDispatcher/dispatchEventFunction()
	at flash.events::EventDispatcher/dispatchEvent()
	at flash.net::URLLoader/onComplete()

But I don't see that when i run with AsyncInit off.

Can you tell me anything about the code behind this error? Could this be because of the missing button.xml?
Given that disabling async plugin init helps to workaround this issue and the fact that we don't have a patch ready, this will be a wontfix for 41. If a patch is available in the next few days, please nominate for uplift to Beta41.
Right now I think we need more information about what is going on. I'd like some more details as outlined in comment 8.
Is this still an issue ? Works for me with latest nightly in windows-7.

--
Version 	50.0a1
Build ID 	20160616030228
Update Channel 	nightly
User Agent 	Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0
We're not working on asyncinit (and not shipping it by default). Resolving.
Status: REOPENED → RESOLVED
Closed: 7 years ago6 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(a_plancher)
You need to log in before you can comment on or make changes to this bug.