"Passifox" add-on does not work with e10s

RESOLVED INCOMPLETE

Status

()

Firefox
Extension Compatibility
RESOLVED INCOMPLETE
3 years ago
6 months ago

People

(Reporter: Vincent Meurisse, Unassigned)

Tracking

42 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150824004008

Steps to reproduce:

- install passifox (https://addons.mozilla.org/en-GB/firefox/addon/passifox/), keepass, and configure them to communicate. (I did this long time ago. I can't confirm if it's working whith e10s)
- Make sure your keepass database is close
- Go to a page that require some credential
- open your keepass database
- right click on the username field and select "Fill User & Pass".


Actual results:

Firefox completelly freeze. I waited severall minutes and the UI is completelly blocked. Even the button to close the window is inactive. The only way out of this is to kill the process.


Expected results:

The username and password should be filled.

Note that if the keepass database is openned when we navigate to the page, the fields are correcly prefilled.
(Reporter)

Updated

3 years ago
Component: Untriaged → Extension Compatibility

Updated

3 years ago
Blocks: 905436
With Firefox 57 only WebExtensions are permitted and are, by default, e10s compatible.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.