The PIN is not automatically blocked after 5 failed attempts

RESOLVED WONTFIX

Status

P2
normal
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: madalin.cotetiu, Assigned: andy+bugzilla)

Tracking

({regression})

Avenir
2015-09-01
regression
Points:
---

Details

(URL)

(Reporter)

Description

3 years ago
Steps to reproduce:
1. Find a paid app and click on it's price button. (i.e: https://marketplace.allizom.org/app/newnewnew-48/?src=new)
2. Enter 5 times an incorrect pin .
--- the pin should be locked at this moment
3. Wait 5 minutes for the pin to be unlocked
4. Click again on the price button, click the continue button and enter an incorrect pin as many times as you want

Expected results:
After five incorrect attempts the pin is locked.

Actual results:
The user is able to enter incorrect pins as many times as he wants.

Notes/Issues:
Verified in FF43(Win7, Android 4.2.1) FFOS 2.5(Flame)

Sometimes  after following the first 2 steps the pin is not locked and the following message is displayed "Your PIN was locked because you entered it incorrectly too many times. You can continue and try entering your PIN again or reset your PIN."  At that moment the user is able to click continue and enter incorrect pins as many times as he wants. Both issues can be seen in this screencast:  http://screencast.com/t/9t4Kv6a3NE
This second issue is only reproducing intermittently.
Assignee: nobody → amckay
Keywords: regression
Priority: -- → P2
Target Milestone: 2015-08-25 → 2015-09-01
Huh. I can't reproduce this on stage or prod. When I get to the screen with the Continue button (step 4), it always re-locks my account after the 5th incorrect PIN entry.
(Reporter)

Comment 2

3 years ago
I can still reproduce this issue. Sometimes I can enter as many incorrect pins as I want sometimes it locks the pin after some random number of incorrect attempts. As you can see here after the 9th attempt the pin was locked: http://screencast.com/t/d8OEQqMrNj (it should be on the 5th attempt)

This is the app I used to test this issue:  https://marketplace.allizom.org/app/test-app-test-paid-app-stage?src=new
Yeah, it's weird, my user account doesn't reproduce it but Krupa and Andy were also able to reproduce it so we have some data to dig into this now.
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.