Closed Bug 1198294 Opened 6 years ago Closed 6 years ago

[New keywords API] Keyword "lost" by changing bookmark URL

Categories

(Firefox :: Bookmarks & History, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1150678

People

(Reporter: myf, Unassigned)

References

Details

Steps to reproduce:
1) Bookmark this page
2) Open Bookmark manager
3) Find this bookmark (by [original URL] or title or whatever)
4) Set it some keyword (eg. "test")
5) Adjust its URL, eg. appending "#hash" at the end (= [altered URL])
6) Close bookmark manager
7) Repeat 2) and 3)

Actual results:
Keyword is "lost". Actually it remained set to [original URL], but is not searchable nor visible and thus 'deletable' in the Bookmark manager unless some bookmark gets the [original URL]. [1]

Expected results:
Perhaps bookmark should be "transferred" to the new URL of the bookmark, like it was before transition to the new API.

Browsers tested and affected:
Firefox 40.0.2, Nightly 43.0a1 (2015-08-24)

Notes:
This appears to be logical consequence of bug 1140395

[1] Insert relevant reference to a bug requesting return of "keyword" column in bookmark manager.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1150678
You need to log in before you can comment on or make changes to this bug.