"Show all downloads" window stops updating progress

RESOLVED WORKSFORME

Status

()

Firefox
Downloads Panel
RESOLVED WORKSFORME
2 years ago
a year ago

People

(Reporter: Lars T Hansen, Unassigned)

Tracking

45 Branch
Unspecified
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150812163655

Steps to reproduce:

I had a half-hour download (900+ MB) so I opened the "show all downloads" window to monitor the download while it was going on.  Around the 400MB mark I stepped away from my computer and when I came back the window was stuck on 508MB and no longer progressing.  But in actuality the download had finished, it was just that the window had stopped updating.

I don't know if this is reproducible, but the file in question was the CUDA 7 toolkit "Local installer", see here: https://developer.nvidia.com/cuda-downloads?sid=932633


Actual results:

The window stopped updating progress in the middle of the download.


Expected results:

The window should have continued to update progress until the download was finished.

Comment 1

2 years ago
Bug not reproduced on W8.1, FF40 AND FF 43.0a1 (2015-08-30)
But i've got fiber (download took me less than 2 minutes) and I've got a Pentium 3,2 Ghz with 8Go RAM

Comment 2

2 years ago
It may have been a one time glitch

Do you still sees this?
(and if it happens again, what the progress indicator in toolbar says then and opening a new downloads list - in progress / finished?)
Flags: needinfo?(lth)

Comment 3

2 years ago
Not reproduced neither on Ubuntu 14.04 
(try do reproduce it on W7 pls. (And remember: a bug which cannot be reproduced is NOT a bug)

Comment 4

2 years ago
Yeah, I sort of know what a bug is...

Probably won't be able to get to this until tonight at the earliest.

Comment 5

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20151125030231

Hi,
I have tested this with Nighlty 45.0a1(2015-11-25) and I can't reproduce this issue.
Please download the Firefox Nightly from here: https://nightly.mozilla.org/ and retest the problem.
Do you still have this problem?

Comment 6

2 years ago
Sorry, I have not tried to repro, I am so rarely on Windows any more :(

Comment 7

2 years ago
Hi Lars,

No problem, I will close this bug: Resolved works for me, and if you can reproduce this issue please reopen the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME

Comment 8

2 years ago
On Windows 8.1 , Nightly 45.0a1 (2015-11-26)
4 tests. Bug reproduced 3 times.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---

Comment 9

2 years ago
Thank you for your help Xavier.
Status: REOPENED → NEW
Component: Untriaged → Downloads Panel
OS: Unspecified → All
Version: 40 Branch → 45 Branch

Comment 10

2 years ago
As they say in movies: "Just doing my job" ;)

Not reproduced after 5 tests on Ubuntu 14.04 with files ~1Go


Fx Release: 42.


CPU:
vendor_id	: GenuineIntel
cpu family	: 6
model		: 60
model name	: Intel(R) Pentium(R) CPU G3258 @ 3.20GHz
stepping	: 3
microcode	: 0x19
cpu MHz		: 2700.000
cache size	: 3072 KB

Note: I've got fiber

Comment 11

2 years ago
It seems that it works with other files. Perhaps it comes from a link only.
Hi,

You reproduce this problem on Win 8.1 only with 1 link?
Flags: needinfo?(xavier.delgado)
I tried to reproduce with latest Nightly 45.0a1 (2015-11-27) e10s enabled and disabled on Windows 8.1 64-bit, but without success. I tried about 5-6 times with different profiles each time using the link from comment 0, more exactly http://developer.download.nvidia.com/compute/cuda/7.5/Prod/local_installers/cuda_7.5.18_windows.exe. 

I also tried with other files larger then 1GB with the same result.

Comment 14

2 years ago
I've tried 4 times downloads ~1GB. Bug not reproduced.

Issue only happens with this link. http://developer.download.nvidia.com/compute/cuda/7.5/Prod/local_installers/cuda_7.5.18_windows.exe 
and not all the time.
Flags: needinfo?(xavier.delgado)

Comment 15

a year ago
We made a lot of changes to the code in the last year, so this issue might be gone by now. I'm closing this bug again, but feel free to reopen if it's still reproducible for you.
Status: NEW → RESOLVED
Last Resolved: 2 years agoa year ago
Flags: needinfo?(lth)
Resolution: --- → WORKSFORME

Comment 16

a year ago
Bug not reproduced.


Intel(R) Pentium(R) CPU G3258 @ 3.20GHz

Nightly 53.0a1 (2016-11-24) (64-bit)

Comment 17

a year ago
Bug not reproduced.


Intel(R) Pentium(R) CPU G3258 @ 3.20GHz

Nightly 53.0a1 (2016-11-24) (64-bit)

Windows 10
You need to log in before you can comment on or make changes to this bug.