chrome.browserAction.onClicked.addListener needs the tabs permission to access tab.url.

RESOLVED DUPLICATE of bug 1190688

Status

defect
RESOLVED DUPLICATE of bug 1190688
4 years ago
11 months ago

People

(Reporter: bwinton, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(firefox43 affected)

Details

The sample code at http://src.chromium.org/viewvc/chrome/trunk/src/chrome/common/extensions/docs/examples/api/browserAction/make_page_red/background.js says that it shouldn't need "tabs" or "host" permissions in the handler.

https://dxr.mozilla.org/mozilla-central/source/browser/components/extensions/ext-utils.js#86 looks like the line where the magic occurs (or doesn't occur in this case ;).
This extension is actually using the activeTab permission. That's still something we need to implement.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1190688

Updated

11 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.