"Welcome to ..." needs a bottom border on the standalone UI

VERIFIED FIXED in Firefox 43

Status

Hello (Loop)
Client
P1
normal
Rank:
19
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

({regression})

unspecified
mozilla43
regression
Points:
2
Bug Flags:
firefox-backlog +
in-testsuite +

Firefox Tracking Flags

(firefox43 verified)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

2 years ago
This is a recent regression in the context improvements.

The "Welcome to ..." has no bottom padding if there's no context displayed on the standalone UI. As a result, it looks strange, and hence we need to fix it.

We need to be careful, as we can't just take the padding from the context element and put it on the room name, as the desktop UI needs it.
(Assignee)

Comment 1

2 years ago
Created attachment 8652486 [details] [diff] [review]
'Welcome to ...' needs a bottom border on the Loop standalone UI.

This fixes it, though the additional css isn't really my favourite. Due to the need to have the top padding on desktop but not standalone, this seems the most reasonable way for it.

Mike, before I add tests, what do you think?
Attachment #8652486 - Flags: feedback?(mdeboer)
Comment on attachment 8652486 [details] [diff] [review]
'Welcome to ...' needs a bottom border on the Loop standalone UI.

Review of attachment 8652486 [details] [diff] [review]:
-----------------------------------------------------------------

I can't think of better way. Go for it!
Attachment #8652486 - Flags: feedback?(mdeboer) → feedback+
(Assignee)

Comment 3

2 years ago
Created attachment 8652796 [details]
Screen shot of fix

Before is on the left, after in the middle, and the bits on the right are showing it with context for reference.
Attachment #8652796 - Flags: ui-review?(sfranks)
(Assignee)

Updated

2 years ago
Depends on: 1157646
(Assignee)

Comment 4

2 years ago
Created attachment 8652812 [details] [diff] [review]
'Welcome to ...' needs a bottom border on the Loop standalone UI.

Updated patch with unit tests, depends on tidy up in bug 1157646.
Attachment #8652486 - Attachment is obsolete: true
Attachment #8652812 - Flags: review?(mdeboer)
(Assignee)

Updated

2 years ago
Attachment #8652796 - Attachment is patch: false
Attachment #8652796 - Attachment mime type: text/plain → image/png
Comment on attachment 8652812 [details] [diff] [review]
'Welcome to ...' needs a bottom border on the Loop standalone UI.

Review of attachment 8652812 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM!
Attachment #8652812 - Flags: review?(mdeboer) → review+
Comment on attachment 8652796 [details]
Screen shot of fix

Looks great. Thanks, Mark!
Attachment #8652796 - Flags: ui-review?(sfranks) → ui-review+
(Assignee)

Updated

2 years ago
Rank: 19
Flags: qe-verify+
Flags: firefox-backlog+
https://hg.mozilla.org/mozilla-central/rev/cdc4dc6af449
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox43: --- → fixed
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
QA Contact: bogdan.maris
Was unable to reproduce the initial behavior but I can confirm the updated bottom border in Standalone UI using latest Nightly 43.0a1 across platforms (Windows 7 64-bit, Mac OS X 10.10.5 and Ubuntu 14.04 32-bit).
Status: RESOLVED → VERIFIED
status-firefox43: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.