Closed Bug 1198507 Opened 6 years ago Closed 6 years ago

Notifications aren't launching in Logviewer

Categories

(Tree Management :: Treeherder, defect, P2)

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: jfrench, Assigned: jfrench)

References

Details

(Keywords: regression)

Attachments

(1 file)

46 bytes, text/x-github-pull-request
emorley
: review+
Details | Review
It appears that Notifications are no longer working in Logviewer.

It was working correctly last week on stage, when I verified on stage bug 1193216 and bug 1193222.

In the interim it means that neither of those bugfixes are working properly. The partial appears to be missing on stage:

"Error: [$compile:tpload] Failed to load template: partials/main/thNotificationsBox.html (HTTP status: 404 NOT FOUND)
Keywords: regression
Maybe we need to specifically add partials/main/thNotificationsBox.html (only) for logviewer here for grunt
https://github.com/mozilla/treeherder/blob/master/Gruntfile.js#L183

..ie. similar to what we do for treeherder itself, where we grab everything
https://github.com/mozilla/treeherder/blob/master/Gruntfile.js#L162
Actually, that makes no sense. It worked on stage prior without it.
(In reply to Jonathan French (:jfrench) from comment #2)
> Actually, that makes no sense. It worked on stage prior without it.

Today the Apache configs were adjusted on stage. Prior to that, SERVE_MINIFIED_UI was not set (since we weren't using WhiteNoise officially yet on stage/prod), which meant files served by gunicorn/WhiteNoise were served from `ui/` not `dist/`. Now this basically was a no-op on the most part, since the apache config intercepted most requests and served them from disk, from `dist/` - and no nothing was supposed to be getting as far as WhiteNoise. However the odd URI would have slipped past the old Apache config, including `partials/`, looking at bug 1197799 comment 2.

tl;dr it worked until now on stage due to a bug which meant that the URLs for some of the unminified assets would still resolve on stage/prod, but that has now been fixed in bug 1197799, so we'll need to update the Gruntfile.
Yeah, there's a 404 in the console:

23:33:47.457 GET https://treeherder.allizom.org/partials/main/thNotificationsBox.html [HTTP/1.1 404 NOT FOUND 160ms]

With the missing Gruntfile entry added, the grunt build will mean it doesn't try and access the partial directly.
Awesome, thank you for the context Ed :)
Assignee: nobody → tojonmz
Status: NEW → ASSIGNED
Attached file PR 915
Tweak PR for review.
Attachment #8652864 - Flags: review?(emorley)
Comment on attachment 8652864 [details] [review]
PR 915

Thank you :-)
Attachment #8652864 - Flags: review?(emorley) → review+
Marking fixed per above merge.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
And verified fixed on production.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.