Switch tabs with Ctrl+Tab in most recently used order




Tabbed Browser
3 years ago
2 years ago


(Reporter: Yves Goergen, Unassigned)


40 Branch

Firefox Tracking Flags

(Not tracked)




3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150812163655

Steps to reproduce:

Press Ctrl+Tab to switch between two related tabs.

Actual results:

The tab that's right of the current tab is selected.

Expected results:

The tab that was most recently selected should be selected. Because that's what I want when I press a hotkey to switch tabs. Because I switch tabs to compare them, not to make a world travel through all other tabs. Because I need to do it quickly, hence pressing a hotkey, not using the mouse. Because Alt+Tab in every OS does the same. Because at least half of the text editors and IDEs do the same with Ctrl+Tab. Because there's a huge demand from Firefox users. Because the Addon SDK isn't capable of filling that gap. Because all addons are broken for some time and the core is the only stable place to add that feature.

Comment 1

2 years ago

Hi, thank you for the feedback and for taking the time to report this, but for now this is how Firefox works, also in the future versions this may change. Thank you again for your time. 
Regarding the bug problem, technically speaking this is not a bug, so I can only close out this bug.


2 years ago
Severity: normal → enhancement
Component: Untriaged → Keyboard Navigation


2 years ago
Last Resolved: 2 years ago
Component: Keyboard Navigation → Tabbed Browser
Resolution: --- → DUPLICATE
Duplicate of bug: 178556

Comment 3

2 years ago
The other bug is broken and since the issue still exists, this one cannot be a duplicate of the other bug.
Resolution: DUPLICATE → ---

Comment 4

2 years ago
(In reply to Yves Goergen from comment #3)
> The other bug is broken and since the issue still exists, this one cannot be
> a duplicate of the other bug.

I don't think it has any differences and progress with the once bugs and discussion.

I guess the browser.ctrlTab.previews in about:config suit your needs. Or do you mean to https://addons.mozilla.org/firefox/addon/mru-tabs/?
Flags: needinfo?(nospam)

Comment 5

2 years ago
Wow, the "browser.ctrlTab.previews" setting looks a lot like a solution to this bug. It changes the tab switching order from "tab bar order" to "most recently used" (MRU) which is exactly what I was asking for. I'll keep and try this for a while. Makes Ctrl+Tab useful again. Interesting that wasn't mentioned in the other bug.

It does have a popup window like Windows' Alt+Tab which I'm not the biggest fan of. I also noticed that the window doesn't even appear when I press and complete the hotkey quickly. But as the tabs are not switched immediately but only once after the Ctrl key has been released, the window is necessary when skipping a tab. I think I'm okay with that window.

That add-on is my work but it never reached 100% reliability and failed very often in recent Firefox versions which is why I'm not using it anymore myself. It tries and intercepts key events that are also handled by Firefox itself and that seems to cause some race conditions at times. I should probably delete or "unpublish" it again.
Flags: needinfo?(nospam)
You need to log in before you can comment on or make changes to this bug.