Spell checker language always re-defaults to a specific language

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: alexander.buchner, Unassigned)

Tracking

38 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.4 Safari/537.36

Steps to reproduce:

1. Open the message compose window.
2. Check what's the default spell checker language.
3. Change the language to something you want (for the current mail).
4. Send your mail.
5. In the next mail it re-defaults to the language from step 2 and not the one I chose in step 3.



Expected results:

In earlier versions Thunderbird just remembered the last language I chose.
Remembering the last language you chose imo is not helpful for most scenarios.
If your default language is EN and you're picking Spanish once to write to your friend there, it does not imply that your next message should be Spanish again. We'll get other users complaining, why do you remember my once-only choice. Chances of getting it wrong by remembering are much higher than otherwise.

But you can define your desired default language in

Tools > options > composition > Spelling > language

Does that help?

(wfm)
(Reporter)

Comment 2

3 years ago
Ah, I didn't know this setting.

This helps a lot since the default was set (by whoever?!) to the language I use least.
Thanks for rapid feedback, we're glad to help.

wfm per comment 1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.