Get submit 2 times in an utf-8 encode page

VERIFIED WORKSFORME

Status

()

--
major
VERIFIED WORKSFORME
17 years ago
4 years ago

People

(Reporter: j.queinnec, Assigned: nhottanscp)

Tracking

({intl})

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
In an html page encoding in utf-8 with some form using "get" method, the submit
is do 2 times.
The page is indicated useing UTF-8 by this meta information :
<meta http-equiv="Content-Type" content="text/html;charset=UTF-8">
If you configure the server to send the same information, the problem also occur.

If the form method is post, the problem don't occur.
If using the menu view, character coding, you force "utf-8" the problem don't
occur. 
This problem was existed in moz 0.9.4 and previous. It was corrected after (but
I don't know the bug number) and moz have no problem in 0.9.5, 0.9.6 and 0.9.7
releases. Since one week, the problem re-occur.
I couldn(t see you the page problem, because it is on an intranet and private site.

Comment 1

17 years ago
what's probably happening is that the encoding stuff is triggering a new load from necko but isn't using the cached version.  upping the severity.
Assignee: alexsavulov → yokoyama
Severity: normal → major
Component: Form Submission → Internationalization
QA Contact: vladimire → ruixu

Comment 2

17 years ago
nhotta: can you take a look at this?
Assignee: yokoyama → nhotta
(Assignee)

Comment 3

17 years ago
Cc to harishd. 
Harish, I think there is a special handling for META is that for 'get' or 'post'?

Updated

17 years ago
QA Contact: ruixu → ylong

Comment 4

17 years ago
reporter, please creat test case

Comment 5

17 years ago
bug 61363 I believe
Keywords: qawanted

Updated

17 years ago
Keywords: intl

Comment 6

17 years ago
j.queinnec@comidoc.fr: could you nicely attach a test cases for this ?
(Reporter)

Comment 7

17 years ago
I've try to make a test but I can't.
Two possibles raisons :
1 - my problem was on invalid html page and with some correction on it, the
problem don't occur again.
2 - the problem is fiwed on actual version of Mozilla (RC1+).

On the 2 cases, invalid/fixed bug I think.

Comment 8

17 years ago
worksforme per reporter's  comments. thanks for the followup.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 9

17 years ago
verified.
Status: RESOLVED → VERIFIED
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.