Closed Bug 1198658 Opened 5 years ago Closed 5 years ago

[Flame KK][Message]Press the download button, there is no message indicating that you need to switch data connection.

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

VERIFIED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: qiutian, Assigned: steveck)

Details

(Keywords: regression, smoketest)

Attachments

(4 files)

Attached video Flame_user_2.5.3gp
[1.Description]:
[Flame KK v2.5][Message]Set SIM 1 as primary outgoing data, enable Auto retrieve on with roaming( on SIM 2), SIM 2 receive a MMS, tap the "Download" button on MMS, the message indicating that you need to switch data connection does not pop up.
Found time:5:22
See attachements:logcat_522.txt,Flame_user_2.5.3gp

[2.Testing Steps]: 
1. Go to Settings > SIM manager, set SIM 1 as primary outgoing data. 
2. Go to Settings > Message settings, enable Auto retrieve on with roaming( on SIM 2). 
3. Send MMS to SIM 2. 
4. Open the received MMS. 
5. Press the download button. 

[3.Expected Result]: 
In step 5, a warning message indicating that you need to switch data connection should be shown., and MMS attachment will be downloaded successfully. 

[4.Actual Result]: 
In step 5, there is no a warning message pop up, the MMS attachment will display "Downloading" all the time.

[5.Reproduction build]: 
Device: Flame KK 2.2 (Eng) (Unaffected)
Build ID               20150825032504
Gaia Revision          335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gaia Date              2015-08-14 19:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1effc4cb6414
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150825.065824
Firmware Date          Tue Aug 25 06:58:37 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.5 (User) (Affected)
Build ID               20150825150204
Gaia Revision          a8a462ab783a5bbab508d3c29483cff260672e3c
Gaia Date              2015-08-25 04:21:06
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c46370eea81a9860ae77d1f0c7776c24e816138e
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150825.183028
Firmware Date          Tue Aug 25 18:30:41 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.5 (Eng) (Affected)
Build ID               20150825064341
Gaia Revision          b441bde54293bea5254dc340845effe951fa3906
Gaia Date              2015-08-24 17:47:19
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f3df9cd1701f617418ebf1a7a5947150d5d24939
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150825.102309
Firmware Date          Tue Aug 25 10:23:22 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
10739

[8.Note]:
Because of Aries only support one SIM card, this problem can't be tried on Aries KK v2.5.
Attached file logcat_522.txt
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame KK 2.5
Gaia-Rev        f704940a921dd7edfcfdc881e4208dd878eb691b
Gecko-Rev       https://hg.mozilla.org/integration/b2g-inbound/rev/a0deba98fde2a86b26c32b33e623ef526a377426
Build-ID        20150820043436
Version         43.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150820.183055
FW-Date         Thu Aug 20 18:31:07 EDT 2015
Base Image               v18D v4
Bootloader      L1TC000118D0

First Broken Environmental Variables:
Device: Flame KK 2.5
Gaia-Rev        7afe8bd5d34b70a053620a2480df05c8f827bcec
Gecko-Rev       https://hg.mozilla.org/integration/b2g-inbound/rev/d8ed39774e6c81668ffc585e0a22d85e67baa4f0
Build-ID        20150820045936
Version         43.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150820.183055
FW-Date         Thu Aug 20 18:31:07 EDT 2015
Base Image               v18D v4
Bootloader      L1TC000118D0


First Broken Gaia & Last Working Gecko - issue DOES repro
Gaia Revision          7afe8bd5d34b70a053620a2480df05c8f827bcec
Gecko Revision         a0deba98fde2a86b26c32b33e623ef526a377426

First Broken Gecko & Last Working Gaia - issue DOES NOT repro
Gaia Revision          f704940a921dd7edfcfdc881e4208dd878eb691b
Gecko Revision         d8ed39774e6c81668ffc585e0a22d85e67baa4f0

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/f704940a921dd7edfcfdc881e4208dd878eb691b...7afe8bd5d34b70a053620a2480df05c8f827bcec


Possibly caused by Bug 1184865.
Keywords: smoketest
Hi Steve,

This bug is caused by bug 1184865, could you help to check? thanks. :)
Flags: needinfo?(schung)
[Blocking Requested - why for this release]:

You shouldn't need to switch data connection. Maybe we don't pass the right arguments though.
blocking-b2g: --- → 2.5?
Looks like a regression. Blocks 2.5
blocking-b2g: 2.5? → 2.5+
I found that we also need to clone the DOMError instance in this case. Will fix it ASAP.
Assignee: nobody → schung
Flags: needinfo?(schung)
Comment on attachment 8653306 [details] [review]
[gaia] steveck-chung:bug-1198658-DOMError-clone > mozilla-b2g:master

Hi Julien, it's dataclone error(DOMError could not be cloned) in this case. I simply create a object with name property, not sure if you prefer to return as normal error instance in this case.
Attachment #8653306 - Flags: review?(felash)
Create an issue about supporting DOMError in bridge: https://github.com/gaia-components/bridge/issues/80(Added into the comment in shim).
Comment on attachment 8653306 [details] [review]
[gaia] steveck-chung:bug-1198658-DOMError-clone > mozilla-b2g:master

r=me

please fix the comment (file a separate bug for Core:DOM) and file a separate bug to fix the same issue in split views mode (with bug 1183133 + rehash manifests).
Attachment #8653306 - Flags: review?(felash) → review+
Landed in master: https://github.com/mozilla-b2g/gaia/commit/2f4ea12f07b928eabb127382c79844d30f21c38b

Create bug 1200496 for DOMError clone, but I can't reproduce the issue in split view. I'm sure that the test is in split mode because there's no animation while view transition and notification is not working. Hi Julien, if you still face the problem on your device, could you please simplify the test with single sim and make sure the MMS retrieval is enabled on the test sim? Or any error log would be helpful too, thanks!
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
This bug has been verified as "pass" on the latest user/eng build of Flame KK v2.5 by the STR in comment 0.

Actual results: a warning message indicating that you need to switch data connection will be shown, and MMS attachment will be downloaded successfully. 

See attachment: Verified_FlameKK_user_v2.5.3gp
Reproduce rate: 0/10

Device: Flame KK 2.5 User(Pass)
Build ID               20150901150204
Gaia Revision          c2582f4be03cd12124b96a263c8d14c774f0ffe4
Gaia Date              2015-09-01 17:03:45
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e47423c019643792e6de894cfcee598dead4d3ba
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150901.182918
Firmware Date          Tue Sep  1 18:29:28 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.5 Eng(Pass)
Build ID               20150901150204
Gaia Revision          c2582f4be03cd12124b96a263c8d14c774f0ffe4
Gaia Date              2015-09-01 17:03:45
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e47423c019643792e6de894cfcee598dead4d3ba
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150901.182949
Firmware Date          Tue Sep  1 18:30:04 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.