Option to show search suggestions in location bar should be disabled in permanent private browsing mode

VERIFIED FIXED in Firefox 43

Status

()

defect
P3
normal
Rank:
33
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: petruta.rasa, Assigned: adw)

Tracking

42 Branch
Firefox 43
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox43 verified)

Details

(Whiteboard: [suggestions][fxsearch])

Attachments

(2 attachments)

Reproduced with Dev Edition 42.0a2 and Nightly 43.0a1 2015-08-25 across platforms.

Steps to reproduce:
1. Set the browser to permanent browse privately (never remember history)
2. Open about:preferences#search
3. Tick the "Show search suggestions in location bar results" checkbox 

Actual results:
The option can be selected

Expected results:
The second checkbox should be disabled in permanent private browsing mode (maybe in private windows too) as the search suggestions in location bar are not displayed when browsing privately.
ui glitch, not critical imo.
The problematic part is that permanent PB can be disabled elsewhere and in that case we might have to also uncheck the checkbox or it would look like disabled but active. So we will need to fake the pref status in the UI.
Flags: firefox-backlog+
Priority: -- → P3
Whiteboard: [suggestions][fxsearch]

Updated

4 years ago
Rank: 33
Assignee

Comment 2

4 years ago
Stephen, I have a patch that disables the urlbar suggestions checkbox when permanent PB mode is enabled.  What do you think about showing some text explaining why it's disabled in that case, as this screenshot shows?
Assignee: nobody → adw
Status: NEW → ASSIGNED
Attachment #8661394 - Flags: feedback?(shorlander)
Assignee

Comment 3

4 years ago
Comment on attachment 8661394 [details]
Screenshot of explanatory text when permanent PB mode is enabled

Stephen said over IRC that he's fine with this.
Attachment #8661394 - Flags: feedback?(shorlander)
Assignee

Comment 4

4 years ago
Posted patch patchSplinter Review
This (1) unchecks the urlbar suggestions checkbox whenever it's disabled, and (2) shows some explanatory text when permanent PB mode is enabled, as shown in the screenshot in comment 2.
Attachment #8661409 - Flags: review?(dtownsend)
Comment on attachment 8661409 [details] [diff] [review]
patch

Review of attachment 8661409 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/components/preferences/in-content/search.js
@@ +62,5 @@
>      this._initAutocomplete();
>  
> +    let suggestsPref =
> +      document.getElementById("browser.search.suggest.enabled");
> +    suggestsPref.addEventListener("change", () => {

Should we be listening for browser.privatebrowsing.autostart changes too?
Attachment #8661409 - Flags: review?(dtownsend) → review+
Assignee

Comment 6

4 years ago
A previous version of this patch did, but I removed for simplicity's sake because the only way to toggle it in the UI is in the Privacy pane (I think?), and when you do that, you're forced to restart the browser.  Should I add it back?
Flags: needinfo?(dtownsend)
(In reply to Drew Willcoxon :adw from comment #6)
> A previous version of this patch did, but I removed for simplicity's sake
> because the only way to toggle it in the UI is in the Privacy pane (I
> think?), and when you do that, you're forced to restart the browser.  Should
> I add it back?

Oh yeah forgot it needed a restart. No need then
Flags: needinfo?(dtownsend)
https://hg.mozilla.org/mozilla-central/rev/bb4c100934bc
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
Verified the message and checkbox in permanent private browsing mode using Dev Edition 43.0a2 2015-09-23 under Win 7 64-bit, Ubuntu 12.040 32-bit and Mac OS X 10.9.5.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.