e10s crash in mozilla::ipc::FatalError | mozilla::layers::PLayerTransactionParent::Read with a11y active

RESOLVED WORKSFORME

Status

()

Core
Graphics: Layers
P2
critical
RESOLVED WORKSFORME
2 years ago
a year ago

People

(Reporter: lizzard, Assigned: nical)

Tracking

(Blocks: 1 bug, {crash, reproducible})

40 Branch
Unspecified
All
crash, reproducible
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+, firefox43+ wontfix, firefox44+ wontfix, firefox45- wontfix, firefox46- affected, firefox47 affected)

Details

(Whiteboard: [gfx-noted], aes+, crash signature)

Attachments

(1 attachment)

This bug was filed from the Socorro interface and is 
report bp-eb13225e-0354-4b52-9b46-663052150825.
=============================================================
Several similar crash signatures showed up in Nightly for the first time this week; combined they would be in the top 10 crashing signatures.  

First appearing: 2015-08-21

Crashing thread: 

0 	xul.dll 	mozilla::ipc::FatalError(char const*, char const*, unsigned long, bool) 	ipc/glue/ProtocolUtils.cpp
1 	xul.dll 	mozilla::layers::PLayerTransactionParent::FatalError(char const* const) 	obj-firefox/ipc/ipdl/PLayerTransactionParent.cpp
2 	xul.dll 	mozilla::layers::PLayerTransactionParent::Read(mozilla::layers::SurfaceDescriptorShmem*, IPC::Message const*, void**) 	obj-firefox/ipc/ipdl/PLayerTransactionParent.cpp
3 	xul.dll 	mozilla::layers::PLayerTransactionParent::Read(mozilla::layers::SurfaceDescriptor*, IPC::Message const*, void**) 	obj-firefox/ipc/ipdl/PLayerTransactionParent.cpp
4 	xul.dll 	mozilla::layers::PLayerTransactionParent::OnMessageReceived(IPC::Message const&) 	obj-firefox/ipc/ipdl/PLayerTransactionParent.cpp
5 	xul.dll 	mozilla::layers::PCompositorParent::OnMessageReceived(IPC::Message const&) 	obj-firefox/ipc/ipdl/PCompositorParent.cpp
6 	xul.dll 	mozilla::ipc::MessageChannel::DispatchMessageW(IPC::Message const&) 	ipc/glue/MessageChannel.cpp
7 	xul.dll 	mozilla::ipc::MessageChannel::OnMaybeDequeueOne() 	ipc/glue/MessageChannel.cpp
8 	xul.dll 	MessageLoop::DoWork() 	ipc/chromium/src/base/message_loop.cc
9 	xul.dll 	base::MessagePumpForUI::DoRunLoop() 	ipc/chromium/src/base/message_pump_win.cc
(Reporter)

Updated

2 years ago
Crash Signature: [@ mozilla::ipc::FatalError(char const*, char const*, unsigned long, bool) | mozilla::layers::PLayerTransactionParent::FatalError(char const* const) | mozilla::layers::PLayerTransactionParent::Read(mozilla::layers::SurfaceDescriptorShmem*, IPC::Mes… → [@ mozilla::ipc::FatalError(char const*, char const*, unsigned long, bool) | mozilla::layers::PLayerTransactionParent::FatalError(char const* const) | mozilla::layers::PLayerTransactionParent::Read(mozilla::layers::SurfaceDescriptorShmem*, IPC::Mes…
Whiteboard: gfx-noted
I can reproduce this on nightly OS X, by going to workday and clicking on "Personal Information".  Now, this workflow was my way of reproducing bug 1191400 (bug 1191465, fixed by backing out bug 1181908), though the crash signatures were completely different.  Proof by example - Workday -> Personal Information is a good sanity test :)
Keywords: regressionwindow-wanted
Whiteboard: gfx-noted
This one was mine: https://crash-stats.mozilla.com/report/index/d70fcf44-7a65-42b6-a651-6f9812150909
And now the reproducible "Workday -> Personal Information" workflow is no more.
I've hit this twice today.

Looks like it's failing to deserialize a SurfaceDescriptorShmem object and aborting.

This is all autogenerated code, I'm not sure how invalid data could have ever got there.

Can we get a regression range for the nightly where this started?
Based on crash-stats it looks like this started with Firefox 43.0a1 20150820030202. 

Here is the pushlog for that range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f384789a29dcfd514d25d4a16a97ec5309612d78&tochange=29b2df16e961fbe9a379362ecba6f888d1754bc3
FYI, there are two bugs mentioning IPC in that range:
* bug 1191976 - [e10s] Some child process crashes are not being reported
* bug 1180555 - [Bluetooth] Handle PBAP replies from Gaia and pass the results to PbapManager.

Not sure if these could be related.
http://hg.mozilla.org/mozilla-central/rev/5078ba83b951

Mike Conley — Bug 1191976 - Intentionally crash if we hit an IPC FatalError in the parent process. r=billm
Unfortunately that's a really unhelpful blame target, since it's just when we started crashing the browser in response to the error, not when the error was introduced.

CC'ing Bill and Mike anyway in case they have ideas about the possible causes of this error.
Skimming through that bug, it appears that this was the exact error they were hoping to have reported. So that's nice :)

Not sure it gets us much closer to knowing the cause though.
Does the STR in https://bugzilla.mozilla.org/show_bug.cgi?id=1191976#c1 work for you? Sorry, we focused too much on crash reporting in that bug and forgot to address the actual crash.
(In reply to Bill McCloskey (:billm) from comment #10)
> Does the STR in https://bugzilla.mozilla.org/show_bug.cgi?id=1191976#c1 work for you?

I've been trying those steps and it doesn't crash for me. Perhaps Matt and/or Milan could give it a try though.
I've been hitting this crash almost every time when I run a nightly while compiling at the same time.  At first glance it seems like we end up with memory pressure, something doesn't deal, and we end up aborting the parent process...

I know that's not much to go on.  :(
bkelly's wild guess is that it's the CPU contention that's being the problem, with something in IPC code timing out, possibly.
Trying to do a build under "nice" seemed to work better.... I'll see if that consistently prevents the crash.
And now I just hit the crash while running a "nice" build.
And now I've hit it 4 times in the last hour, all while running "nice" builds.  Going to disable e10s again.  :(
tracking-e10s: --- → ?
Assignee: nobody → gwright
tracking-e10s: ? → m8+

Updated

2 years ago
Crash Signature: [@ mozilla::ipc::FatalError(char const*, char const*, unsigned long, bool) | mozilla::layers::PLayerTransactionParent::FatalError(char const* const) | mozilla::layers::PLayerTransactionParent::Read(mozilla::layers::SurfaceDescriptorShmem*, IPC::Mes… → [@ mozilla::ipc::FatalError(char const*, char const*, unsigned long, bool) | mozilla::layers::PLayerTransactionParent::FatalError(char const* const) | mozilla::layers::PLayerTransactionParent::Read(mozilla::layers::SurfaceDescriptorShmem*, IPC::Mes…
I can reproduce this by visiting:
https://www.youtube.com/playlist?list=PLuU1suLgDIUJfZJl-94SZr2BnRZuaIlEV
Keywords: reproducible
Also when I zoom into:
http://i.imgur.com/uE2Kkh6.jpg
If you get time, can you try narrowing it down with mozregression? http://mozilla.github.io/mozregression/
Flags: needinfo?(bgirard)
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #19)
> If you get time, can you try narrowing it down with mozregression?
> http://mozilla.github.io/mozregression/

If it helps you get a head start: based on crash-stats I think this happened between the 0929 and 0930 builds (though there was a respin that day so I'm not sure which)
My examples above no longer reproduce for me.
Flags: needinfo?(bgirard)

Comment 22

2 years ago
Firefox Dev list suggested I post this here
(see firefox-dev Digest, Vol 34, Issue 9)
>
>     I have had some problems with this site before - its the official
>     online site for tv programs free to air on New Zealand TV.
>
>     Its OK in Firefox (release version), and in Chrome, IE etc but not
>     in Nightly.
>
>     http://www.freeviewnz.tv/tvguide/whats-on/
>
>     To reproduce:
>
>     1 - Load page.  Its unusual in that it loads twice - once showing
>     programs starting at midnight and then repaints for the correct
>     time.   That may be just bad design, although less obvious in
>     other browsers.
>     As its loading the status line shows "read usetypekit.net
>     <http://usetypekit.net>"
>
>     2 - Once loaded all looks OK.   Try to scroll the page up or down
>     or sideways.   Scrolling using the scroll bars works OK, 
      but scrolling using laptop trackpad click in grid and drag (up/down or left/right) does not -         and crashes
      (Scrolling using mouse dragging on page not tested because I don't have one)
      The page on my PC then goes blank, cannot be
>     reloaded, in fact no tabs will render properly after this - it
>     seems to have somehow trashed the entire rendering engine.
>
>     Note I have AdblockPlus extension installed - but I have disabled
>     it for this page.
>
>     3 - Restarting Nightly in safe mode produces the same problem
>     although it crashed slightly more gradually, but soon did crash
>     entirely with the full bug report
>
>     AdapterDeviceID: 0x0416
>     AdapterDriverVersion: 10.18.14.4170
>     AdapterSubsysID: 1966103c
>     AdapterVendorID: 0x8086
>     AvailablePageFile: 9519321088 <tel:9519321088>
>     AvailablePhysicalMemory: 8356245504 <tel:8356245504>
>     AvailableVirtualMemory: 1095516160
>     BIOS_Manufacturer: Insyde
>     BlockedDllList:
>     BreakpadReserveAddress: 45613056
>     BreakpadReserveSize: 67108864
>     BuildID: 20151006030231
>     CrashTime: 1444202587
>     DOMIPCEnabled: 1
>     EMCheckCompatibility: true
>     EventLoopNestingLevel: 1
>     FramePoisonBase: 00000000f0de0000
>     FramePoisonSize: 65536
>     IPCFatalErrorMsg: Error deserializing 'data' (Shmem) member of
>     'SurfaceDescriptorShmem'
>     IPCFatalErrorProtocol: PLayerTransactionParent
>     InstallTime: 1444201473
>     Notes: Cisco VPN
>     AdapterVendorID: 0x8086, AdapterDeviceID: 0x0416, AdapterSubsysID:
>     1966103c, AdapterDriverVersion: 10.18.14.4170
>     Has dual GPUs. GPU #2: AdapterVendorID2: 0x10de, AdapterDeviceID2:
>     0x1292, AdapterSubsysID2: 1966103c, AdapterDriverVersion2:
>     9.18.13.3165
>     ProductID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
>     ProductName: Firefox
>     ReleaseChannel: nightly
>     SafeMode: 1
>     SecondsSinceLastCrash: 1282342
>     StartupTime: 1444202525
>     SystemMemoryUsePercentage: 51
>     TelemetryEnvironment:
>     {"build":{"applicationId":"{ec8030f7-c20a-464f-9b0e-13a3a9e97384}","applicationName":"Firefox","architecture":"x86","buildId":"20151006030231","version":"44.0a1","vendor":"Mozilla","platformVersion":"44.0a1","xpcomAbi":"x86-msvc","hotfixVersion":"20150902.02"},"partner":{"distributionId":null,"distributionVersion":null,"partnerId":null,"distributor":null,"distributorChannel":null,"partnerNames":[]},"system":{"memoryMB":16316,"virtualMaxMB":4096,"cpu":{"count":8,"cores":4,"vendor":"GenuineIntel","family":6,"model":60,"stepping":3,"l2cacheKB":256,"l3cacheKB":6144,"speedMHz":2394,"extensions":["hasMMX","hasSSE","hasSSE2","hasSSE3","hasSSSE3","hasSSE4_1","hasSSE4_2"]},"os":{"name":"Windows_NT","version":"6.3","locale":"en-NZ","servicePackMajor":0,"servicePackMinor":0,"installYear":2013},"hdd":{"profile":{"model":"ST1000LM024
>     HN-M101MBB","revision":"2AR20002"},"binary":{"model":"ST1000LM024
>     HN-M101MBB","revision":"2AR20002"},"system":{"model":"ST1000LM024
>     HN-M101MBB","revision":"2AR20002"}},"gfx":{"D2DEnabled":false,"DWriteEnabled":false,"adapters":[{"description":"Intel(R)
>     HD Graphics
>     4600","vendorID":"0x8086","deviceID":"0x0416","subsysID":"1966103c","RAM":null,"driver":"igdumdim64
>     igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32
>     igd10iumd32","driverVersion":"10.18.14.4170","driverDate":"3-16-2015","GPUActive":true},{"description":"NVIDIA
>     GeForce GT 740M
>     ","vendorID":"0x10de","deviceID":"0x1292","subsysID":"1966103c","RAM":2048,"driver":"nvd3dumx,nvwgf2umx,nvwgf2umx
>     nvd3dum,nvwgf2um,nvwgf2um","driverVersion":"9.18.13.3165","driverDate":"10-23-2013"}],"monitors":[{"screenWidth":1920,"screenHeight":1080,"refreshRate":60,"pseudoDisplay":false}],"features":{"compositor":"basic","d3d11":{"status":"blocked"},"d2d":{"status":"unavailable","version":"1.0"}}},"isWow64":true},"settings":{"blocklistEnabled":true,"e10sEnabled":true,"telemetryEnabled":true,"isInOptoutSample":false,"locale":"en-US","update":{"channel":"nightly","enabled":true,"autoDownload":true},"userPrefs":{"browser.cache.disk.capacity":358400,"browser.newtabpage.enhanced":true,"browser.shell.checkDefaultBrowser":false,"browser.startup.homepage":"<user-set>","browser.startup.page":3,"browser.urlbar.suggest.searches":true,"browser.urlbar.userMadeSearchSuggestionsChoice":true},"addonCompatibilityCheckEnabled":true,"isDefaultBrowser":false},"profile":{"creationDate":16059},"addons":{"activeAddons":{},"theme":{},"activePlugins":[{"name":"WildTangent
>     Games App V2 Presence
>     Detector","version":"4.0.5.13","description":"WildTangent Games
>     App V2 Presence
>     Detector","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/wildtangent-gamesapp-detector-plugin"],"updateDay":15625},{"name":"Google
>     Update","version":"1.3.28.15","description":"Google
>     Update","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-vnd.google.update3webcontrol.3","application/x-vnd.google.oneclickctrl.9"],"updateDay":16692},{"name":"Photo
>     Gallery","version":"16.4.3528.331","description":"NPWLPG","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-wlpg3-detect","application/x-wlpg-detect"],"updateDay":16160},{"name":"Microsoft
>     Office 2010","version":"14.0.4730.1010","description":"Office
>     Authorization plug-in for NPAPI
>     browsers","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-msoffice14"],"updateDay":14618},{"name":"Microsoft
>     Office 2010","version":"14.0.4761.1000","description":"The plug-in
>     allows you to open and edit files using Microsoft Office
>     applications","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-sharepoint"],"updateDay":14692},{"name":"Silverlight
>     Plug-In","version":"5.1.40416.0","description":"5.1.40416.0","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-silverlight","application/x-silverlight-2"],"updateDay":16540},{"name":"Intel?
>     Identity Protection
>     Technology","version":"4.0.5.0","description":"Intel web
>     components for Intel? Identity Protection
>     Technology","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-vnd-intel-webapi-ipt-4.0.5"],"updateDay":15925},{"name":"Intel?
>     Identity Protection
>     Technology","version":"4.0.5.0","description":"Intel web
>     components updater - Installs and updates the Intel web
>     components","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-vnd-intel-webapi-updater"],"updateDay":15925},{"name":"Google
>     Earth
>     Plugin","version":"7.1.5.1557","description":"GEPlugin","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/geplugin"],"updateDay":16575},{"name":"FortiClient
>     SSLVPN CacheCleaner Firefox
>     Plugin","version":"4.0.2294.0","description":"FortiClient SSLVPN
>     CacheCleaner Firefox
>     Plugin","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-forticacheclean-plugin","application/x-forticacheclean-plugin;version=4.0.2294.0","application/x-forticacheclean-plugin;version=3.0.379.0","application/x-forticacheclean-plugin;version=3.0.383.0","application/x-forticacheclean-plugin;version=3.0.387.0"],"updateDay":15966},{"name":"FortiClient
>     SSLVPN Tunnel Service FireFox
>     Plugin","version":"4.0.2294.0","description":"FortiClient SSLVPN
>     Tunnel Service Firefox
>     Plugin","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-forticontrol-plugin","application/x-forticontrol-plugin;version=4.0.2294.0","application/x-forticontrol-plugin;version=3.0.379.0","application/x-forticontrol-plugin;version=3.0.383.0","application/x-forticontrol-plugin;version=3.0.387.0"],"updateDay":15966},{"name":"Citrix
>     ICA Client","version":"14.1.200.13","description":"Citrix Receiver
>     Plugin
>     (Win32)","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-ica"],"updateDay":16315},{"name":"Citrix
>     URL-Redirection Helper Plugin
>     ","version":"14.1.200.13","description":"Citrix URL-Redirection
>     Helper Plugin
>     ","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/npurlinterceptor"],"updateDay":16315},{"name":"Simple
>     Pass","version":"6.0.100.276","description":"Website Logon
>     Plugin","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/npwlo"],"updateDay":15862},{"name":"Shockwave
>     for Director","version":"11.6.6.636","description":"Adobe
>     Shockwave for Director Netscape plug-in, version
>     11.6.6.636","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-director"],"updateDay":15560},{"name":"Shockwave
>     Flash","version":"12.0.0.70","description":"Shockwave Flash 12.0
>     r0","blocklisted":false,"disabled":false,"clicktoplay":false,"mimeTypes":["application/x-shockwave-flash","application/futuresplash"],"updateDay":16121},{"name":"Shockwave
>     Flash","version":"19.0.0.185","description":"Shockwave Flash 19.0
>     r0","blocklisted":false,"disabled":false,"clicktoplay":false,"mimeTypes":["application/x-shockwave-flash","application/futuresplash"],"updateDay":16700},{"name":"VSeeDetection","version":"1.0.0.0","description":"Used
>     to make VSee installation status and version number accessible via
>     JavaScript","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-vseedetection"],"updateDay":16086},{"name":"Google
>     Update","version":"1.3.28.15","description":"Google
>     Update","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-vnd.google.update3webcontrol.3","application/x-vnd.google.oneclickctrl.9"],"updateDay":16696},{"name":"Google
>     Earth
>     Plugin","version":"6.2.0.5788","description":"GEPlugin","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/geplugin"],"updateDay":15444},{"name":"Citrix
>     Online Web Deployment Plugin
>     1.0.0.104","version":"1.0.0.104","description":"Citrix Online App
>     Detector
>     Plugin","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-col-application-detector"],"updateDay":16190},{"name":"Google
>     Talk Plugin","version":"5.41.2.0","description":"Version
>     5.41.2.0","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/googletalk"],"updateDay":16542},{"name":"Google
>     Talk Plugin Video
>     Renderer","version":"5.41.2.0","description":"Version
>     5.41.2.0","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/o1d"],"updateDay":16542}],"activeGMPlugins":{"gmp-gmpopenh264":{"version":"1.4","userDisabled":false,"applyBackgroundUpdates":1},"gmp-eme-adobe":{"version":"14","userDisabled":false,"applyBackgroundUpdates":1}},"activeExperiment":{},"persona":null}}
>     Theme: classic/1.0
>     Throttleable: 1
>     TotalPageFile: 19658727424
>     TotalPhysicalMemory: 17108590592 <tel:17108590592>
>     TotalVirtualMemory: 4294836224
>     URL: http://www.freeviewnz.tv/tvguide/whats-on/
>     Vendor: Mozilla
>     Version: 44.0a1
>     Winsock_LSP: MSAFD Tcpip [TCP/IP] : 2 : 1 :
>     %SystemRoot%\system32\mswsock.dll
>     MSAFD Tcpip [UDP/IP] : 2 : 2 :
>     MSAFD Tcpip [RAW/IP] : 2 : 3 : %SystemRoot%\system32\mswsock.dll
>     MSAFD Tcpip [TCP/IPv6] : 2 : 1 :
>     MSAFD Tcpip [UDP/IPv6] : 2 : 2 : %SystemRoot%\system32\mswsock.dll
>     MSAFD Tcpip [RAW/IPv6] : 2 : 3 :
>     RSVP TCPv6 Service Provider : 2 : 1 :
>     %SystemRoot%\system32\mswsock.dll
>     RSVP TCP Service Provider : 2 : 1 :
>     RSVP UDPv6 Service Provider : 2 : 2 :
>     %SystemRoot%\system32\mswsock.dll
>     RSVP UDP Service Provider : 2 : 2 :
>     MSAFD RfComm [Bluetooth] : 2 : 1 : %SystemRoot%\system32\mswsock.dll
>     useragent_locale: en-US
>
>     This report also contains technical information about the state of
>     the application when it crashed.
>
>     [end of bug report details]
>
>     Windows 8.1 64 bit Intel i7 Haswell cpu   HP Laptop using trackpad
>
>     Curious if its a problem with the browser or the site.
>
>     _______________________________________________
>     firefox-dev mailing list
>     firefox-dev@mozilla.org <mailto:firefox-dev@mozilla.org>
>     https://mail.mozilla.org/listinfo/firefox-dev
>

Comment 23

2 years ago
(In reply to John Bird from comment #22)
> Firefox Dev list suggested I post this here
> (see firefox-dev Digest, Vol 34, Issue 9)
> >     BuildID: 20151006030231

This build is almost a week old, I'd be interested if it still happens in current builds as IIRC some patches landed that may help this.

Updated

2 years ago
Crash Signature: [@ mozilla::ipc::FatalError(char const*, char const*, unsigned long, bool) | mozilla::layers::PLayerTransactionParent::FatalError(char const* const) | mozilla::layers::PLayerTransactionParent::Read(mozilla::layers::SurfaceDescriptorShmem*, IPC::Mes&hellip; → [@ mozilla::ipc::FatalError(char const*, char const*, unsigned long, bool) | mozilla::layers::PLayerTransactionParent::FatalError(char const* const) | mozilla::layers::PLayerTransactionParent::Read(mozilla::layers::SurfaceDescriptorShmem*, IPC::Mes&hellip;
(Reporter)

Comment 24

2 years ago
Still happening on aurora and nightly both, but not as frequently as a couple of weeks ago.
(Reporter)

Comment 25

2 years ago
And those crashes are all on OS X.

Comment 26

2 years ago
Tried same again, Windows 8.1 HP Laptop - note it is 2 finger scolling on trackpad that triggers it, and it still crashes every time.   In Safe Mode it gives a crash report ( normal mode it goes gaga menus work but no pages in any tab are displayed.)

AdapterDeviceID: 0x0416
AdapterDriverVersion: 10.18.14.4170
AdapterSubsysID: 1966103c
AdapterVendorID: 0x8086
AvailablePageFile: 12966723584
AvailablePhysicalMemory: 10459111424
AvailableVirtualMemory: 945094656
BIOS_Manufacturer: Insyde
BlockedDllList: 
BreakpadReserveAddress: 42270720
BreakpadReserveSize: 67108864
BuildID: 20151015030233
CrashTime: 1444982399
DOMIPCEnabled: 1
EMCheckCompatibility: true
Email: johnkbird@paradise.net.nz
FramePoisonBase: 00000000f0de0000
FramePoisonSize: 65536
IPCFatalErrorMsg: Error deserializing 'data' (Shmem) member of 'SurfaceDescriptorShmem'
IPCFatalErrorProtocol: PLayerTransactionParent
InstallTime: 1444982326
MozCrashReason: MOZ_CRASH(IPC FatalError in the parent process!)
Notes: Cisco VPN
AdapterVendorID: 0x8086, AdapterDeviceID: 0x0416, AdapterSubsysID: 1966103c, AdapterDriverVersion: 10.18.14.4170
Has dual GPUs. GPU #2: AdapterVendorID2: 0x10de, AdapterDeviceID2: 0x1292, AdapterSubsysID2: 1966103c, AdapterDriverVersion2: 9.18.13.3165
ProductID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
ProductName: Firefox
ReleaseChannel: nightly
SafeMode: 1
SecondsSinceLastCrash: 779812
StartupTime: 1444982326
SystemMemoryUsePercentage: 38
TelemetryEnvironment: {"build":{"applicationId":"{ec8030f7-c20a-464f-9b0e-13a3a9e97384}","applicationName":"Firefox","architecture":"x86","buildId":"20151015030233","version":"44.0a1","vendor":"Mozilla","platformVersion":"44.0a1","xpcomAbi":"x86-msvc","hotfixVersion":"20150902.02"},"partner":{"distributionId":null,"distributionVersion":null,"partnerId":null,"distributor":null,"distributorChannel":null,"partnerNames":[]},"system":{"memoryMB":16316,"virtualMaxMB":4096,"cpu":{"count":8,"cores":4,"vendor":"GenuineIntel","family":6,"model":60,"stepping":3,"l2cacheKB":256,"l3cacheKB":6144,"speedMHz":2394,"extensions":["hasMMX","hasSSE","hasSSE2","hasSSE3","hasSSSE3","hasSSE4_1","hasSSE4_2"]},"os":{"name":"Windows_NT","version":"6.3","locale":"en-NZ","servicePackMajor":0,"servicePackMinor":0,"installYear":2013},"hdd":{"profile":{"model":"ST1000LM024 HN-M101MBB","revision":"2AR20002"},"binary":{"model":"ST1000LM024 HN-M101MBB","revision":"2AR20002"},"system":{"model":"ST1000LM024 HN-M101MBB","revision":"2AR20002"}},"gfx":{"D2DEnabled":false,"DWriteEnabled":false,"adapters":[{"description":"Intel(R) HD Graphics 4600","vendorID":"0x8086","deviceID":"0x0416","subsysID":"1966103c","RAM":null,"driver":"igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32","driverVersion":"10.18.14.4170","driverDate":"3-16-2015","GPUActive":true},{"description":"NVIDIA GeForce GT 740M   ","vendorID":"0x10de","deviceID":"0x1292","subsysID":"1966103c","RAM":2048,"driver":"nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um","driverVersion":"9.18.13.3165","driverDate":"10-23-2013"}],"monitors":[{"screenWidth":1920,"screenHeight":1080,"refreshRate":60,"pseudoDisplay":false}],"features":{"compositor":"basic","d3d11":{"status":"blocked"},"d2d":{"status":"unavailable","version":"1.0"}}},"isWow64":true},"settings":{"blocklistEnabled":true,"e10sEnabled":true,"telemetryEnabled":true,"isInOptoutSample":false,"locale":"en-US","update":{"channel":"nightly","enabled":true,"autoDownload":true},"userPrefs":{"browser.cache.disk.capacity":358400,"browser.newtabpage.enhanced":true,"browser.shell.checkDefaultBrowser":false,"browser.startup.homepage":"<user-set>","browser.startup.page":3,"browser.urlbar.suggest.searches":true,"browser.urlbar.userMadeSearchSuggestionsChoice":true},"addonCompatibilityCheckEnabled":true,"isDefaultBrowser":false},"profile":{"creationDate":16059},"addons":{"activeAddons":{},"theme":{},"activePlugins":[{"name":"WildTangent Games App V2 Presence Detector","version":"4.0.5.13","description":"WildTangent Games App V2 Presence Detector","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/wildtangent-gamesapp-detector-plugin"],"updateDay":15625},{"name":"Google Update","version":"1.3.28.15","description":"Google Update","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-vnd.google.update3webcontrol.3","application/x-vnd.google.oneclickctrl.9"],"updateDay":16692},{"name":"Photo Gallery","version":"16.4.3528.331","description":"NPWLPG","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-wlpg3-detect","application/x-wlpg-detect"],"updateDay":16160},{"name":"Microsoft Office 2010","version":"14.0.4730.1010","description":"Office Authorization plug-in for NPAPI browsers","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-msoffice14"],"updateDay":14618},{"name":"Microsoft Office 2010","version":"14.0.4761.1000","description":"The plug-in allows you to open and edit files using Microsoft Office applications","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-sharepoint"],"updateDay":14692},{"name":"Silverlight Plug-In","version":"5.1.40416.0","description":"5.1.40416.0","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-silverlight","application/x-silverlight-2"],"updateDay":16540},{"name":"Intel® Identity Protection Technology","version":"4.0.5.0","description":"Intel web components for Intel® Identity Protection Technology","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-vnd-intel-webapi-ipt-4.0.5"],"updateDay":15925},{"name":"Intel® Identity Protection Technology","version":"4.0.5.0","description":"Intel web components updater - Installs and updates the Intel web components","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-vnd-intel-webapi-updater"],"updateDay":15925},{"name":"Google Earth Plugin","version":"7.1.5.1557","description":"GEPlugin","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/geplugin"],"updateDay":16575},{"name":"FortiClient SSLVPN CacheCleaner Firefox Plugin","version":"4.0.2294.0","description":"FortiClient SSLVPN CacheCleaner Firefox Plugin","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-forticacheclean-plugin","application/x-forticacheclean-plugin;version=4.0.2294.0","application/x-forticacheclean-plugin;version=3.0.379.0","application/x-forticacheclean-plugin;version=3.0.383.0","application/x-forticacheclean-plugin;version=3.0.387.0"],"updateDay":15966},{"name":"FortiClient SSLVPN Tunnel Service FireFox Plugin","version":"4.0.2294.0","description":"FortiClient SSLVPN Tunnel Service Firefox Plugin","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-forticontrol-plugin","application/x-forticontrol-plugin;version=4.0.2294.0","application/x-forticontrol-plugin;version=3.0.379.0","application/x-forticontrol-plugin;version=3.0.383.0","application/x-forticontrol-plugin;version=3.0.387.0"],"updateDay":15966},{"name":"Citrix ICA Client","version":"14.1.200.13","description":"Citrix Receiver Plugin (Win32)","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-ica"],"updateDay":16315},{"name":"Citrix URL-Redirection Helper Plugin ","version":"14.1.200.13","description":"Citrix URL-Redirection Helper Plugin ","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/npurlinterceptor"],"updateDay":16315},{"name":"Simple Pass","version":"6.0.100.276","description":"Website Logon Plugin","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/npwlo"],"updateDay":15862},{"name":"Shockwave for Director","version":"11.6.6.636","description":"Adobe Shockwave for Director Netscape plug-in, version 11.6.6.636","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-director"],"updateDay":15560},{"name":"Shockwave Flash","version":"12.0.0.70","description":"Shockwave Flash 12.0 r0","blocklisted":false,"disabled":false,"clicktoplay":false,"mimeTypes":["application/x-shockwave-flash","application/futuresplash"],"updateDay":16121},{"name":"Shockwave Flash","version":"19.0.0.207","description":"Shockwave Flash 19.0 r0","blocklisted":false,"disabled":false,"clicktoplay":false,"mimeTypes":["application/x-shockwave-flash","application/futuresplash"],"updateDay":16722},{"name":"VSeeDetection","version":"1.0.0.0","description":"Used to make VSee installation status and version number accessible via JavaScript","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-vseedetection"],"updateDay":16086},{"name":"Google Update","version":"1.3.28.15","description":"Google Update","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-vnd.google.update3webcontrol.3","application/x-vnd.google.oneclickctrl.9"],"updateDay":16696},{"name":"Google Earth Plugin","version":"6.2.0.5788","description":"GEPlugin","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/geplugin"],"updateDay":15444},{"name":"Citrix Online Web Deployment Plugin 1.0.0.104","version":"1.0.0.104","description":"Citrix Online App Detector Plugin","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-col-application-detector"],"updateDay":16190},{"name":"Google Talk Plugin","version":"5.41.2.0","description":"Version 5.41.2.0","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/googletalk"],"updateDay":16542},{"name":"Google Talk Plugin Video Renderer","version":"5.41.2.0","description":"Version 5.41.2.0","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/o1d"],"updateDay":16542}],"activeGMPlugins":{"gmp-gmpopenh264":{"version":"1.4","userDisabled":false,"applyBackgroundUpdates":1},"gmp-eme-adobe":{"version":"14","userDisabled":false,"applyBackgroundUpdates":1}},"activeExperiment":{},"persona":null}}
Theme: classic/1.0
Throttleable: 1
TotalPageFile: 19658727424
TotalPhysicalMemory: 17108590592
TotalVirtualMemory: 4294836224
URL: http://www.freeviewnz.tv/tvguide/whats-on/
Vendor: Mozilla
Version: 44.0a1
Winsock_LSP: MSAFD Tcpip [TCP/IP] : 2 : 1 : %SystemRoot%\system32\mswsock.dll 
 MSAFD Tcpip [UDP/IP] : 2 : 2 :  
 MSAFD Tcpip [RAW/IP] : 2 : 3 : %SystemRoot%\system32\mswsock.dll 
 MSAFD Tcpip [TCP/IPv6] : 2 : 1 :  
 MSAFD Tcpip [UDP/IPv6] : 2 : 2 : %SystemRoot%\system32\mswsock.dll 
 MSAFD Tcpip [RAW/IPv6] : 2 : 3 :  
 RSVP TCPv6 Service Provider : 2 : 1 : %SystemRoot%\system32\mswsock.dll 
 RSVP TCP Service Provider : 2 : 1 :  
 RSVP UDPv6 Service Provider : 2 : 2 : %SystemRoot%\system32\mswsock.dll 
 RSVP UDP Service Provider : 2 : 2 :  
 MSAFD RfComm [Bluetooth] : 2 : 1 : %SystemRoot%\system32\mswsock.dll
useragent_locale: en-US

This report also contains technical information about the state of the application when it crashed.
Hit this a few times today just visiting http://m.sportsauthority.com
https://crash-stats.mozilla.com/report/index/04fab0c8-1ad8-421f-b047-cf24c2151016

Environmental Variables:
Device: Aries Master
Build ID: 20151016122951
Gaia: 8999f0ba6326d815c8366e3c1155b7e4e9763b40
Gecko: ccf288f658211b6cfab33c458aaf033baed2375b
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (Master)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
Created attachment 8675047 [details]
logs.txt
I have twice reproduced this crash in Nightly 44 on OS X when trying to reproduce bug 1191220.

STR:
1. Open http://www.dash-player.com/demo/manifest-test/
2. Enter the following MPD URL into the video player and press the LOAD button:
http://storage.googleapis.com/widevine-demo-media/sintel-1080p/dash.mpd

RESULT:
In my primary user profile, Nightly 44 hangs. If I then click the video's play button, Nightly crashes:

bp-8d79f58f-4259-4ae2-ba00-98c2b2151018
bp-172cf9ce-bdbb-400d-b1f5-3dbf52151018

In a cleaner test profile, Nightly 44 plays the video correctly without crashing.
OS: Windows NT → All
Hardware: x86 → Unspecified
See Also: → bug 1191220
I saw the following assertion failures on stderr from crash bp-89021c7c-b987-45da-b829-c0a6b2151018:

###!!! [Child][DispatchAsyncMessage] Error: (msgtype=0xFFFB,name=???) Payload error: message could not be deserialized

IPDL protocol error: Error deserializing 'data' (Shmem) member of 'SurfaceDescriptorShmem'
[NPAPI 24968] ###!!! ABORT: Aborting on channel error.: file /builds/slave/m-cen-m64-ntly-000000000000000/build/src/ipc/glue/MessageChannel.cpp, line 1769
[NPAPI 24968] ###!!! ABORT: Aborting on channel error.: file /builds/slave/m-cen-m64-ntly-000000000000000/build/src/ipc/glue/MessageChannel.cpp, line 1769
On OS X, I bisected this crash to bug 1157746 ("Enable APZ on OS X desktop nightly builds"):

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6ad92b48085b5ec5532f14e0b9e3c5eb15ad9fa8&tochange=cfc312d8ef205bcb6a58b840459a4ccd922dcf88
Blocks: 1157746
Kats, is this a dupe of a known issue?
Flags: needinfo?(bugmail.mozilla)
(Reporter)

Comment 33

2 years ago
Tracking for 43. This is a topcrash for 43 and also seems to affect 44.
status-firefox44: --- → affected
tracking-firefox43: --- → +
tracking-firefox44: --- → +
Keywords: topcrash
The only dupage I'm aware of is that this looks like bug 1196119 but that hasn't gone anywhere either. That one has STR though so maybe it will be easier to track down?
Flags: needinfo?(bugmail.mozilla)
Seeing as this is specific to APZC and not necessarily e10s, do we still want this in m8?
tracking-e10s: m8+ → ?
tracking-e10s: ? → +
This isn't an e10s issue so kicking back to unassigned so Kats can find someone suitable for it.
Assignee: gwright → nobody
Assignee: nobody → nical.bugzilla
See Also: → bug 1221540

Comment 37

2 years ago
bug 1210821 has one of those signatures as well, is it related?
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #37)
> bug 1210821 has one of those signatures as well, is it related?

Depends where the bug is (we corrupt the stream/bug in the transport code vs. we send a bad message). I'd assume that it's not related until we get evidence that it is.
Nicolas, this is showing up as a top crash for Aurora44. I am wondering if there is a patch that is in the works and ready to be uplifted to Aurora. Please let me know. Thanks!
Flags: needinfo?(nical.bugzilla)
(Assignee)

Comment 40

2 years ago
(In reply to Ritu Kothari (:ritu) from comment #39)
> Nicolas, this is showing up as a top crash for Aurora44. I am wondering if
> there is a patch that is in the works and ready to be uplifted to Aurora.
> Please let me know. Thanks!

I don't have a patch for this, and not even a good idea of what is causing the error. There might be multiple things. I believe bz's case (ipc messages timing out when the cpu is under heavy load) is tackled by a separate bug which I don't have handy.
I haven't managed to reproduce any of the STR in this bug on my computer so far.
Flags: needinfo?(nical.bugzilla)

Comment 41

2 years ago
I am on bugzilla on Firefox Developer and crash https://crash-stats.mozilla.com/report/index/800549c0-28b2-452c-b87b-8cb5b2151119
Open sites:
Steam Store, gmail, bugzilla, dhl

Comment 42

2 years ago
http://www.neowin.net/forum/topic/1279088-microsoft-takes-steps-to-protect-edge-from-malicious-code/

For me that page crashes the browser every single time I try to click the "Next" link, not sure if it'll help but I ran with LLDB attached and got this backtrace.

> Process 91961 stopped
> * thread #7: tid = 0x2bdafff, 0x0000000100017a14 libmozglue.dylib`mozalloc_abort(char const*) + 36, name = 'Chrome_ChildThread', stop reason = EXC_BAD_ACCESS (code=1, address=0x0)
>     frame #0: 0x0000000100017a14 libmozglue.dylib`mozalloc_abort(char const*) + 36
> libmozglue.dylib`mozalloc_abort(char const*):
> ->  0x100017a14 <+36>: movl   $0x21, 0x0
>     0x100017a1f <+47>: callq  0x100032cf4               ; symbol stub for: abort
>     0x100017a24 <+52>: nopw   %cs:(%rax,%rax)
> 
> libmozglue.dylib`abort:
>     0x100017a30 <+0>:  pushq  %rbp
> (lldb) thread backtrace 7
> * thread #7: tid = 0x2bdafff, 0x0000000100017a14 libmozglue.dylib`mozalloc_abort(char const*) + 36, name = 'Chrome_ChildThread', stop reason = EXC_BAD_ACCESS (code=1, address=0x0)
>   * frame #0: 0x0000000100017a14 libmozglue.dylib`mozalloc_abort(char const*) + 36
>     frame #1: 0x0000000100473099 XUL`Abort(char const*) + 9
>     frame #2: 0x0000000100472e8f XUL`NS_DebugBreak + 1247
>     frame #3: 0x000000010083e0b2 XUL`mozilla::ipc::MessageChannel::OnChannelErrorFromLink() + 226
>     frame #4: 0x000000010083f870 XUL`non-virtual thunk to mozilla::ipc::ProcessLink::OnChannelError() + 48
>     frame #5: 0x00000001008196e4 XUL`event_base_loop + 2148
>     frame #6: 0x00000001007d2d65 XUL`base::MessagePumpLibevent::Run(base::MessagePump::Delegate*) + 261
>     frame #7: 0x00000001007d11d9 XUL`MessageLoop::Run() + 73
>     frame #8: 0x00000001007e0165 XUL`base::Thread::ThreadMain() + 197
>     frame #9: 0x00000001007e01ba XUL`ThreadFunc(void*) + 10
>     frame #10: 0x00007fff8d7e29b1 libsystem_pthread.dylib`_pthread_body + 131
>     frame #11: 0x00007fff8d7e292e libsystem_pthread.dylib`_pthread_start + 168
>     frame #12: 0x00007fff8d7e0385 libsystem_pthread.dylib`thread_start + 13
(Reporter)

Comment 43

2 years ago
Not seeing a lot of crashes (one or two) for these signatures for 43 beta, likely since APZ isn't enabled on beta.   Marking this wontfix for 43 though we could still possibly take a patch for 44.
status-firefox43: affected → wontfix
This is also one of the startup crashes I run into when testing Nightly with NVDA and E10S enabled.

Comment 45

2 years ago
Topcrash = Accessibility Active
Neither bug 1198765 nor bug 1210821 mention this, guess I'm first to highlight it. No idea if down to one bug or more.

Comment 46

2 years ago
100% of those crashes have e10s on, and 99% of them have accessibility active, so putting that into the summary.
Summary: crash in mozilla::ipc::FatalError(char const*, char const*, unsigned long, bool) | mozilla::layers::PLayerTransactionParent::FatalError(char const* const) | mozilla::layers::PLayerTransactionParent::Read(mozilla::layers::SurfaceDescriptorShmem*, IPC::M... → e10s crash in mozilla::ipc::FatalError | mozilla::layers::PLayerTransactionParent::Read with a11y active

Comment 47

2 years ago
Sounds like bug 1198459 will make this mostly disappear from Dev Edition while a11y+e10s is still being worked on.
Blocks: 1029143
No longer blocks: 1157746

Updated

2 years ago
Crash Signature: [@ mozilla::ipc::FatalError(char const*, char const*, unsigned long, bool) | mozilla::layers::PLayerTransactionParent::FatalError(char const* const) | mozilla::layers::PLayerTransactionParent::Read(mozilla::layers::SurfaceDescriptorShmem*, IPC::Mes&hellip; → [@ mozilla::ipc::FatalError(char const*, char const*, unsigned long, bool) | mozilla::layers::PLayerTransactionParent::FatalError(char const* const) | mozilla::layers::PLayerTransactionParent::Read(mozilla::layers::SurfaceDescriptorShmem*, IPC::Mes&hellip;

Comment 48

2 years ago
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #47)
> Sounds like bug 1198459 will make this mostly disappear from Dev Edition
> while a11y+e10s is still being worked on.

confirmed, last reports for nightly channel were in the 12-11 release, same day bug 1198459 landed.
Doesn't sound like we need a regression window here at this point as the cause is well-understood. Feel free to add it back if I'm misunderstanding.
Keywords: regressionwindow-wanted
e10s will be disabled by default for FF44 (after e10s telemetry experiment ends on Beta2). I believe this is a wontfix for 44. Nom'd for tracking in 45.
status-firefox44: affected → wontfix
status-firefox45: --- → affected
tracking-firefox45: --- → ?

Updated

2 years ago
Blocks: 1234647

Updated

2 years ago
See Also: → bug 1236266
AFAIK, we won't be working on e10s with a11y during the 45 beta cycle. Not tracking. However, we probably want to track this for 46.
status-firefox46: --- → affected
tracking-firefox45: ? → -
tracking-firefox46: --- → +
I'm hitting this fairly reliably on Mozilla's WorkDay instance, after clicking any button on the main (post-login) screen, during the full-page transition.
Actually, I guess I'm seeing the (near-dupe?) bug 1208226, since about:support says a11y is not active for me.
Hey dolske, out of curiosity, do you have layers.progressive-paint set to true?
Flags: needinfo?(dolske)
No. The pref is at the default value (false).
Flags: needinfo?(dolske)

Comment 56

2 years ago
1.Run Firefox beta newer than beta4(no problem on beta4) with settings:
browser.cache.use_new_backend;1
browser.displayedE10SNotice;4
browser.tabs.remote;true
browser.tabs.remote.autostart;true
browser.tabs.remote.autostart.1;true 
browser.tabs.remote.autostart.2;true 
browser.tabs.remote.autostart.3;true 
browser.tabs.remote.disabled-for-a11y;false
browser.tabs.remote.sandbox;on
dom.ipc.plugins.asyncInit.enabled;true
dom.ipc.plugins.flash.disable-protected-mode;true
dom.ipc.plugins.sandbox-level.default;1
dom.ipc.plugins.sandbox-level.flash;1
javascript.options.asyncstack;true
plugin.allow.asyncdrawing;true
security.sandbox.windows.content.moreStrict;true
2.Firefox load home site and crash with signature:
mozilla::ipc::FatalError | mozilla::jsipc::PJavaScriptParent::FatalError | mozilla::jsipc::PJavaScriptParent::Read

https://crash-stats.mozilla.com/report/index/32abf141-f562-47f6-bdad-3a0cb2160112

Comment 57

2 years ago
Also:
dom.compartment_per_addon;true
dom.ipc.processCount;2
I suspect this is a dupe. I'm not seeing this signature anymore after bug 1236266 landed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1236266

Comment 59

2 years ago
OK problem was with LastPass 4.0.1a addon. I install old version 3.2.44a and zero crash
(Reporter)

Comment 60

2 years ago
There are a bunch of signatures listed and some of them are showing reports from just a couple of days ago. Bug 1236266 landed on the 7th (or the week after for 45 and 46)

Crash report comments mention YouTube, FaceBoo, http://wbez.org or http://player.chicagopublicmedia.org/#wbez, and also Microsoft OneDrive.  

So I'm not sure this is a duplicate.  Bill do you still think so? Or would you rather we file a new bug for the remaining crashes?
Status: RESOLVED → REOPENED
Flags: needinfo?(wmccloskey)
Resolution: DUPLICATE → ---
It does seem like there were multiple crashes in that signature. The remaining ones almost all seem to have this on the stack:

mozilla::layers::PLayerTransactionParent::Read(mozilla::layers::SurfaceDescriptorShmem*, IPC::Message const*, void**)

Based on that, I'm hopeful that bug 1208226 will fix this.
Flags: needinfo?(wmccloskey)

Comment 62

2 years ago
Install Firefox 45beta1
Enable e10s, so schange or add:
browser.tabs.remote;true
browser.tabs.remote.autostart;false
browser.tabs.remote.autostart.1;false
browser.tabs.remote.autostart.2;true  
browser.tabs.remote.disabled-for-a11y;false
browser.tabs.remote.force-enable;true

Firefox constantly crash with signature: 
mozilla::ipc::FatalError | mozilla::jsipc::PJavaScriptParent::FatalError | mozilla::jsipc::PJavaScriptParent::Read

Crash report https://crash-stats.mozilla.com/report/index/470e1fdb-226f-4e86-b170-746422160130

Updated

2 years ago
Blocks: 1246180
(Reporter)

Comment 63

2 years ago
Still some crashes showing for 45.0b10. From what I understand though, this a configuration we need to worry about for 46, since we aren't shipping e10s to a11y users in 46. Untracking for 46.
tracking-firefox46: + → -
(Reporter)

Comment 64

2 years ago
Argh. this *isn't* a configuration we should worry about for 46. Typo.
Some of the signatures have disappeared but we have a few remaining:

> mozilla::ipc::FatalError | mozilla::jsipc::PJavaScriptParent::Read
5 crashes in Firefox 45, other crashes are on old Nightly builds we no longer support.

> mozilla::ipc::FatalError | mozilla::layers::PLayerTransactionParent::Read
This is predominantly an Android issue with ~80% of the 165 crashes on Fennec 45.

> mozilla::ipc::FatalError | mozilla::jsipc::PJavaScriptParent::FatalError | mozilla::jsipc::PJavaScriptParent::Read
This has 75 crashes but none on a version we currently support.

> mozilla::ipc::FatalError | mozilla::layers::PLayerTransactionParent::FatalError | mozilla::layers::PLayerTransactionParent::Read
This is the main issue with 533 crashes reported in the last week, nearly 60% of which are in release.

Are we sure this is an e10s-only issue considering the volume on release?

Comment 66

2 years ago
The PLayerTransactionParent issue is not an e10s-only issue, but it may be something different than the issue triggered by e10s. Or it may be where the thumbnailing content process is still triggering this crash.
status-firefox45: affected → wontfix
status-firefox47: --- → affected
Whiteboard: [gfx-noted]

Updated

a year ago
Whiteboard: [gfx-noted] → [gfx-noted], aes-linux, aes-win

Updated

a year ago
Whiteboard: [gfx-noted], aes-linux, aes-win → [gfx-noted], aes+

Updated

a year ago
Crash Signature: , void**)] [@ mozilla::ipc::FatalError | mozilla::jsipc::PJavaScriptParent::Read] [@ mozilla::ipc::FatalError | mozilla::layers::PLayerTransactionParent::Read] [@ mozilla::ipc::FatalError | mozilla::jsipc::PJavaScriptParent::FatalError | mozilla&hellip; → [@ mozilla::ipc::FatalError | mozilla::jsipc::PJavaScriptParent::Read] [@ mozilla::ipc::FatalError | mozilla::layers::PLayerTransactionParent::Read] [@ mozilla::ipc::FatalError | mozilla::jsipc::PJavaScriptParent::FatalError | mozilla::jsipc::PJa&hellip;
Not showing up with a11y - 

https://crash-stats.mozilla.com/search/?product=Firefox&signature=%3Dmozilla%3A%3Aipc%3A%3AFatalError%20%7C%20mozilla%3A%3Alayers%3A%3APLayerTransactionParent%3A%3ARead&accessibility=__true__&_facets=signature&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform#facet-signature
Crash Signature: [@ mozilla::ipc::FatalError | mozilla::jsipc::PJavaScriptParent::Read] [@ mozilla::ipc::FatalError | mozilla::layers::PLayerTransactionParent::Read] [@ mozilla::ipc::FatalError | mozilla::jsipc::PJavaScriptParent::FatalError | mozilla::jsipc::PJa&hellip; → [@ mozilla::ipc::FatalError | mozilla::jsipc::PJavaScriptParent::Read] [@ mozilla::ipc::FatalError | mozilla::jsipc::PJavaScriptParent::FatalError | mozilla::jsipc::PJavaScriptParent::Read] [@ mozilla::ipc::FatalError | mozilla::layers::PLayerTra&hellip;
[@ mozilla::ipc::FatalError | mozilla::layers::PLayerTransactionParent::FatalError | mozilla::layers::PLayerTransactionParent::Read ]

removing this, not accessibility specific.
Crash Signature: [@ mozilla::ipc::FatalError | mozilla::jsipc::PJavaScriptParent::Read] [@ mozilla::ipc::FatalError | mozilla::jsipc::PJavaScriptParent::FatalError | mozilla::jsipc::PJavaScriptParent::Read] [@ mozilla::ipc::FatalError | mozilla::layers::PLayerTra&hellip; → [@ mozilla::ipc::FatalError | mozilla::jsipc::PJavaScriptParent::Read] [@ mozilla::ipc::FatalError | mozilla::jsipc::PJavaScriptParent::FatalError | mozilla::jsipc::PJavaScriptParent::Read]
Priority: -- → P2
(In reply to Jim Mathies [:jimm] from comment #68)
> [@ mozilla::ipc::FatalError |
> mozilla::layers::PLayerTransactionParent::FatalError |
> mozilla::layers::PLayerTransactionParent::Read ]
> 
> removing this, not accessibility specific.

The other signatures do not occur beyond Firefox 45 so if that signature is removed what is this bug tracking?
In addition to comment 69, this no longer occurs at high enough volume to be called a topcrash.
Keywords: topcrash
No longer happening in current releases.
Status: REOPENED → RESOLVED
Last Resolved: 2 years agoa year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.