Add filtering to allocations tree

RESOLVED DUPLICATE of bug 892223

Status

()

Firefox
Developer Tools: Performance Tools (Profiler/Timeline)
P2
normal
RESOLVED DUPLICATE of bug 892223
3 years ago
2 years ago

People

(Reporter: fitzgen, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Often devs only care about allocations that happen with their script/function/whatever on the stack, we should let them filter the tree to only show such allocations.

Example: I'm working on the l20n.js library, whose script is included in a ton of different apps. I want to minimize allocations from my l20n.js file, but I don't really care about the rest of the app that is embedding l20n.js (that's someone else's problem).

Cmd/Ctrl + F -> search term -> tree is filtered to only those stacks (not just frames) matching the search term
Should add filtering to the entire perf tool!
Priority: -- → P2
Triaging. Filter on ADRENOCORTICOTROPIC (yes).
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 892223
You need to log in before you can comment on or make changes to this bug.