v42.0 File dialog does not support keyboard quick navigation anymore

RESOLVED INVALID

Status

()

Core
Widget: Gtk
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: github, Unassigned)

Tracking

42 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150816004012

Steps to reproduce:

Open a file dialog (for example save or open file, save image or link).

Type the first letters of a directory or file name followed by pressing Return.


Actual results:

Nothing. No highlighting of any directory or file, no quick keyboard based navigation within the file dialog.


Expected results:

When I am using a file dialog, usually you can quickly jump through directories by typing the name of it and it will be highlighted. To go to a "Documents/Downloads/firefox" directory, you would type "Docu" [ENTER] "Down" [ENTER] "fire" [ENTER], and you would be there. Quite quick and it is handled like that in pretty much any other file dialog I can think of.
(Reporter)

Updated

2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
(Reporter)

Updated

2 years ago
Component: File Handling → Keyboard: Navigation
(Reporter)

Updated

2 years ago
Component: Keyboard: Navigation → Widget: Gtk
(Reporter)

Comment 1

2 years ago
This time the Component field should be correct. Sorry for the mess.
I see Firefox matching gedit's save file behavior for GTK3 save dialog. The open dialog allows navigating as you mention. I believe this is expected GTK behavior.
(Reporter)

Comment 3

2 years ago
The open dialog does not work for me either, but it actually seems to be an issue with the GTK3 file dialog, not Firefox explicitly.

Is there a way to turn that functionality on or off when calling it?
(Reporter)

Comment 4

2 years ago
I never collided much with the GTK file dialog, but it seems to be *uhm* ****.

PLEASE choose something else!
AFIK we are using the expected file picker. Checking with the project devs to make sure. Andrew or Glandium see comment 0.
Flags: needinfo?(mh+mozilla)
Flags: needinfo?(andrew)
See bug 1182694 comment 3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(mh+mozilla)
Resolution: --- → INVALID
Flags: needinfo?(andrew)
You need to log in before you can comment on or make changes to this bug.