direktbank.at - Javascript Menu does not work

RESOLVED FIXED in May

Status

RESOLVED FIXED
17 years ago
4 years ago

People

(Reporter: rainer_hoerbe, Assigned: peter+bmo)

Tracking

({ecommerce})

unspecified
ecommerce

Details

(Whiteboard: [eurocontest][havefix][havecontact], URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5) Gecko/20011011
BuildID:    2001101117

When I click on a menu item, nothing happens. In IE a submenu will unfold.

Reproducible: Always
Steps to Reproduce:
1. Call up URL
2. Click on any Menu Item, such as 'Fonds'
3. Nothing happens, which is wrong.

Expected Results:  Submenu should unfold below each menu item

Comment 1

17 years ago
It looks like the site uses layers?

Error: theLayer has no properties
Source File: http://www.direktbank.at/jsscripts/movelayer.js
Line: 29

If so, then this should probably go to Evang.

Comment 2

17 years ago
You can see the problem here:
  http://www.direktbank.at/navigation/startseite_menue.html

The site authors have tried to code for Mozilla/N6, for example:

                 <div id="Layer01" etc. >


and up-to-date Macromedia functions, e.g. v4.0 of MM_findObj(): 

function MM_findObj(n, d) { //v4.0
  var p,i,x;
  if(!d) d=document;

  if((p=n.indexOf("?"))>0&&parent.frames.length) {
    d=parent.frames[n.substring(p+1)].document; n=n.substring(0,p);}
  if(!(x=d[n])&&d.all) x=d.all[n]; for (i=0;!x&&i<d.forms.length;i++)              
    x=d.forms[i][n];
  for(i=0;!x&&d.layers&&i<d.layers.length;i++)             
    x=MM_findObj(n,d.layers[i].document);
  if(!x && document.getElementById)
    x=document.getElementById(n);
  
  return x;
}


However, in the file http://www.direktbank.at/jsscripts/movelayer.js,
they try to access a <DIV> such as above via incorrect document.name syntax.
In a typical call to this function, |layerName| == "Layer01" as above:

function AW_MoveLayer(layerName,x,y,isRelative,NSpath,IEpath) { //v1.0
  var isNav, isIE         
  if (parseInt(navigator.appVersion) >= 4) {      
    if (navigator.appName == 'Netscape') {       
       isNav = true      
    } else {             
       isIE = true       
    }                            
  }
                                       
  if(NSpath =='') {       
    if(isIE){ eval('var theLayer='+layerName)}      
    else{eval('var theLayer=document.'+layerName)}  <<<<<<<<<<<<<< THE MISTAKE
  }

                  etc.  
                  etc.


In Mozilla, one must use the document.getElementById("Layer01").
Because of this mistake, the variable |theLayer| gets the value null.
That's why later, we get an error on line 29 as reported above:


 if(isNav){                              
    if(eval(isRelative)){   
       theLayer.top+=eval(y)           
       theLayer.left+=eval(x)  
    } 
    else{ 
       theLayer.top=eval(y) <<<<<<<<<<<<<<<<<<<<<<<<<<<< LINE 29
       theLayer.left=eval(x) 
    } 



This errors because theLayer is null. Reassigning to Evangelism -
Assignee: rogerl → nitot
Status: UNCONFIRMED → NEW
Component: Javascript Engine → Europe: West
Ever confirmed: true
OS: Windows 2000 → All
Product: Browser → Tech Evangelism
QA Contact: pschwartau → caillon
Version: other → unspecified

Comment 3

17 years ago
Phil, you're awesome :)   Thanks for the *great* analysis!
Hardware: PC → All
Summary: Javascript Menu does not work → direktbank.at - Javascript Menu does not work

Updated

17 years ago
Whiteboard: [eurocontest]
have a fix. 
replace http://www.direktbank.at/jsscripts/movelayer.js with the new version im
attaching.
Whiteboard: [eurocontest] → [eurocontest][havefix]

Comment 5

17 years ago
I am not very good in german :-/

Possible contact addresses :

- eroeffnungsservice@direktbank.at

- Kundenservice@direktbank.at

- mailto:Info@direktbank.at
Whiteboard: [eurocontest][havefix] → [eurocontest][havefix][havecontact]
Created attachment 91991 [details]
fixed movelayer.js
can anyone contact them with the fix ?
move...
Assignee: nitot → german
Component: Europe: West → German
QA Contact: z-caillon-obsolete2 → german

Updated

15 years ago
Keywords: ecommerce
(Assignee)

Comment 9

15 years ago
Technical contact address according to website (browsed with IE ,-) 

* ELBAService@privatbank.at
(Assignee)

Comment 10

15 years ago
Got reply from webmaster; they know the problem, but they think, that a lot
browsers are insignificant (so he thinks Mozilla is, too)

But therefore they are providing a non-javascript page:
www.direktbank.at/netscape.html

He adds, that they will redesign their site in about 3 months, which he thinks,
would be a lot more compatible
Status: NEW → ASSIGNED
Target Milestone: --- → May
(Assignee)

Updated

15 years ago
Assignee: german → peter
Status: ASSIGNED → NEW
(Assignee)

Comment 11

15 years ago
seems to be fixed as promised - Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040614 Firefox/0.8
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.