bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

The toolbox can hide toolbox controls when side-docked

RESOLVED WORKSFORME

Status

DevTools
General
RESOLVED WORKSFORME
3 years ago
a month ago

People

(Reporter: canuckistani, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(firefox43 affected)

Details

Attachments

(1 attachment)

Created attachment 8653023 [details]
WebExtensions_-_MozillaWiki.png

See attached screenshot. STR:

* turn on all the toolbox command buttons and maybe a bunch of extensions
* side-dock the toolbox, then drag right

At more extreme settings the toolbox controls ( close, orientation, pop out, settings ) can get pushed off screen. I don't think these controls should ever get pushed off-screen, we should instead come up with an overflow scheme for the toolbox buttons.
Note that I filed bug 1178213 to display tool tabs along the side instead when in side-dock mode. If we did this first, it'd be a lot easier to fix the overflow problem (still I agree we do need to manage overflow properly).
Duplicate of this bug: 1307397
This is now fixed. There's a drop-down menu that contains the overflown tabs and nothing gets pushed off the screen.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WORKSFORME

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.