Startup crash in gfxFontGroup::FindNonItalicFaceForChar(gfxFontFamily*, unsigned int)

RESOLVED DUPLICATE of bug 1197650

Status

()

Core
Graphics: Text
--
critical
RESOLVED DUPLICATE of bug 1197650
3 years ago
3 years ago

People

(Reporter: dmajor, Unassigned)

Tracking

({crash})

41 Branch
x86
Windows NT
crash
Points:
---

Firefox Tracking Flags

(firefox41 affected, firefox42 ?, firefox43 ?)

Details

(crash signature)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-1468e996-cdc6-4e8e-b483-ce5d32150825.
=============================================================

This has one of the highest crash scores on 41.0b4.

Frame 	Module 	Signature 	Source
0 	xul.dll 	gfxFontGroup::FindNonItalicFaceForChar(gfxFontFamily*, unsigned int) 	gfx/thebes/gfxTextRun.cpp
1 	xul.dll 	gfxFontGroup::FindFontForChar(unsigned int, unsigned int, unsigned int, int, gfxFont*, unsigned char*) 	gfx/thebes/gfxTextRun.cpp
2 	xul.dll 	gfxFontGroup::ComputeRanges<unsigned char>(nsTArray<gfxTextRange>&, unsigned char const*, unsigned int, int, unsigned short) 	gfx/thebes/gfxTextRun.cpp
3 	xul.dll 	gfxFontGroup::InitScriptRun<unsigned char>(gfxContext*, gfxTextRun*, unsigned char const*, unsigned int, unsigned int, int, gfxMissingFontRecorder*) 	gfx/thebes/gfxTextRun.cpp
4 	xul.dll 	gfxFontGroup::InitTextRun<unsigned char>(gfxContext*, gfxTextRun*, unsigned char const*, unsigned int, gfxMissingFontRecorder*) 	gfx/thebes/gfxTextRun.cpp
5 	xul.dll 	gfxFontGroup::MakeTextRun(unsigned char const*, unsigned int, gfxTextRunFactory::Parameters const*, unsigned int, gfxMissingFontRecorder*) 	gfx/thebes/gfxTextRun.cpp
6 	xul.dll 	MakeTextRun<unsigned char>(unsigned char const*, unsigned int, gfxFontGroup*, gfxTextRunFactory::Parameters const*, unsigned int, gfxMissingFontRecorder*) 	layout/generic/nsTextFrame.cpp
7 	xul.dll 	BuildTextRunsScanner::BuildTextRunForFrames(void*) 	layout/generic/nsTextFrame.cpp
8 	xul.dll 	BuildTextRunsScanner::FlushFrames(bool, bool) 	layout/generic/nsTextFrame.cpp
9 	xul.dll 	BuildTextRuns 	layout/generic/nsTextFrame.cpp
(Reporter)

Comment 1

3 years ago
[Tracking Requested - why for this release]: Startup crash
status-firefox41: --- → affected
status-firefox42: --- → ?
status-firefox43: --- → ?
tracking-firefox41: --- → ?
(Reporter)

Comment 2

3 years ago
    nsRefPtr<gfxFont> font = fe->FindOrMakeFont(&mStyle, needsBold);
    if (!font->Valid()) {
        return nullptr;
    }

|font| is null here. There are also other places that call FindOrMakeFont without checking the return value. (The name kind of suggests infallible, IMO)
Flags: needinfo?(jdaggett)
jdaggett just fixed this in bug 1197650, I believe. Maybe that should be uplifted?
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1197650
(Reporter)

Comment 4

3 years ago
Thanks! The crash signature wasn't set correctly on that one, so it wasn't visible to Socorro. I'll fix.

Get back to PTO :)
(Reporter)

Updated

3 years ago
tracking-firefox41: ? → ---

Updated

3 years ago
Flags: needinfo?(jdaggett)
You need to log in before you can comment on or make changes to this bug.