Closed Bug 119899 Opened 21 years ago Closed 21 years ago

hebrew text copied from simple text appears as junk when pasted into a textare

Categories

(Core :: Layout: Text and Fonts, defect)

PowerPC
Mac System 9.x
defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla1.2alpha

People

(Reporter: xslf, Assigned: nhottanscp)

Details

(Keywords: intl)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.7+) Gecko/20020111
BuildID:    20022011108

hebrew text copied from simple text appears as junk when pasted into a textare

Reproducible: Always
Steps to Reproduce:
1. Write some mixed Hebrew/English text in simple text Hebrew
2. Copy the text and paste into a textare of a logical web page in mozilla


Actual Results:  the Hebrew text is junk, roman text is ok

Expected Results:  all text should be ok
Mac-specific Bidi bug -> ftang
Assignee: mkaply → ftang
similar to bug 119877
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
give to nhotta, we should take a look at 'STYL' clipboard format too. if it have
a font of a certain script, we could return that charset as the clipboard charset. 
Assignee: ftang → nhotta
Status: ASSIGNED → NEW
Keywords: intl, nsbeta1
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0
nsbeta1- per triage meeting
Keywords: nsbeta1nsbeta1-
Target Milestone: mozilla1.0 → mozilla1.2
Is there anything we can do to help this bug get fixed soner. IMO, these
problems   (together with bug 119877 ) are too major to wait for some future
version of
Mozilla- with them in place, copy/paste of Hebrew text on MacOS is
effectively not there at al

I have to say that this bug is not limited to Mac platform or Hebrew text,
because I am using Windows 2000 server with Mozilla 0.9.9 , and encounter the
same problem when dealing with Chinese (Big5) text. The 8-bit is stripped when
pasted into a
text area.
just tested this with mozilla 1.1b on mac os 9.2.1 from yeda, and this looks ok.
Anyone else still getting this bug?
I think this was fixed by the change for 'styl' support.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.