If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Fake data apps previews are broken with S3

RESOLVED FIXED

Status

Marketplace
General
P2
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: mat, Assigned: ashort)

Tracking

Avenir
Points:
---
Dependency tree / graph

Details

(Reporter)

Description

2 years ago
STR:
- Look at fake data apps on https://marketplace-s3dev.allizom.org/ , like https://marketplace-s3dev.allizom.org/app/exquisite-gyro/

Expected results:
- Previews work

Actual results:
- Previews are not loaded. If you inspect the element and load the URL it's a 404, even though the URL appears to be formed correctly (no extra query string data, it's on the right bucket etc)

Worth noting:
- Videos and icons work fine.
- When submitting an app normally, the previews are working properly.

Updated

2 years ago
Depends on: 1199033
(Reporter)

Comment 1

2 years ago
Because of bug 1198967 it might be annoying to see, but this is still valid.

Taking for instance this fake app: https://marketplace.dev.mozaws.net/app/exquisite-sandwich?src=search

Once cleaned up to work around bug 1198967, the URLs become:
- For the icon, https://mkt-zamboni-public-dev-mktdev1.s3.amazonaws.com/data/shared_storage/uploads/addon_icons/0/1-128.png?modified=782d898d (works fine)
- For the preview, https://mkt-zamboni-public-dev-mktdev1.s3.amazonaws.com/data/shared_storage/uploads/previews/full/0/1.png?modified=1440619529 (does not work)
(Reporter)

Comment 2

2 years ago
(I should have tested with marketplace.s3dev.allizom.org and not marketplace.dev.mowaws.net in my previous comment, but the issue is reproductible on marketplace.s3dev.allizom.org as well)

Updated

2 years ago
Assignee: nobody → ashort
Priority: P1 → P2
(Assignee)

Comment 3

2 years ago
https://github.com/mozilla/zamboni/commit/f5f91302600efedc7efe67d682e0c775c1ab6703
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.