[e10s] Deadlock in e10s Nightly

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: vladan, Unassigned)

Tracking

(Blocks: 1 bug)

38 Branch
Points:
---

Firefox Tracking Flags

(e10s+)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8653244 [details]
deadlock stacks

The browser wouldn't switch tabs (permanent content-process spinner). I tried to open the profiler, but the profiler tab wouldn't open. The parent process was still responsive, so I tried to exit Firefox, and then it just hung.

I attached the main-thread stacks, but I couldn't get the content-process JS stack.

I'm on Windows 10, Nightly 43 from Aug 25th, installed extensions are Gecko Profiler, uBlock Origin, Send Tab to Device, SQLite Manager
Vladan,  Is it reproducible with all of your add-ons disabled?
Flags: needinfo?(vdjeric)
(Reporter)

Comment 2

2 years ago
I've only seen this once, and I haven't reproduced it since I saw it yesterday
Flags: needinfo?(vdjeric)

Updated

2 years ago
Blocks: 1127385

Updated

2 years ago
tracking-e10s: ? → +
Hi guys,

Considering the fact that I can't seem to reproduce this behavior on latest Aurora (46.0a2-20160208004010) and latest Nightly (47.0a1-20160207030402). And the fact that this was only encountered once as per Vladan's comment 2, I am marking this as resolved-worksforme.

If anyone still encounter it, feel free to reopen this and provide additional information on it.

Thanks,
Paul
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.